Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 017 146 раз!

Форум

Добро пожаловать, Гость!

Mod_wsgi

Обсуждение общих вопросов связанных с программой
Dezeter
Сообщения: 3
C нами: 4 года 7 мес

Непрочитанное сообщение Dezeter » 21 мар 2013, 00:37

У кого нибудь получилось подключить mod_wsgi к apache? У меня опен-север откзываеться запускаться с ним.

jean179
Сообщения: 3
C нами: 5 лет

Непрочитанное сообщение jean179 » 23 мар 2013, 08:16

Я прикручивал на 4.8 python
Все прекрасно работает.
#---------------------------------------------#
# Подключение модулей
#---------------------------------------------#

LoadModule wsgi_module modules/mod_wsgi.so

это вставить в Apache-2.4.3_server.conf
Ну и в папку d:\OpenServer\modules\http\Apache-2.4.3\modules\mod_wsgi.so
кинуть сам файл. Файл брал в google code. Внимательно смотрите версию для апача и разрадность системы.

Глюков было море - не запускался. В конце концов после Н-ой попытки встал и заработал на 2.4 апач

Dezeter
Сообщения: 3
C нами: 4 года 7 мес

Непрочитанное сообщение Dezeter » 23 мар 2013, 11:29

Ну хз, я уже и компил его сам, не хочет апач с ним запускаться :(

jean179
Сообщения: 3
C нами: 5 лет

Непрочитанное сообщение jean179 » 23 мар 2013, 14:37

Я же говорю, танцы с бубном были. И так прикручивал, и этак. В конце-концов получилось. По мойму дело в драйвере я wsgi или в настройках openserver. Попробуйте в другой сборки прикрутить, например XAMPP.

А да, обратите ОСОБОЕ внимание на разрядность оси и на ПОДДЕРЖИВАЕМЫЕ ВЕРСИИ - они различаются!

wowas
Сообщения: 2
C нами: 3 года 7 мес
Контакты:

Непрочитанное сообщение wowas » 02 май 2013, 17:54

Проверьте переменную окружения PATH. В ней должны быть прописаны пути к Python.
И в "Настройки/Сервер/Настройка использования переменной Path" выставить "Свой Path + Win Path".

alex-ks
Сообщения: 27
C нами: 4 года 7 мес

Непрочитанное сообщение alex-ks » 20 июл 2013, 15:51

не могу настроить mod_wsgi.
python 2.7.5, win7 64бит, openserver 4.8.7
mod_wsgi.so брал отсюда http://www.lfd.uci.edu/~gohlke/pythonlibs/#mod_wsgi и отсюда http://www.apachelounge.com/viewtopic.php?t=5143
Не запустилось ни с каким.
Настраивал так: в конфиге апача: LoadModule wsgi_module modules/mod_wsgi.so
и в папку с modules кладу скачанные mod_wsgi.so. В интоге не стартует апач.
Апачи пробовал 2.2.24+nginx и 2.4.4 - не работает.
Кому нибудь удавалось настроить?

Глюков было море - не запускался. В конце концов после Н-ой попытки встал и заработал на 2.4 апач

Можете выложить ваш mod_wsgi.so и какая у вас конфигурация сервера?

wowas
Сообщения: 2
C нами: 3 года 7 мес
Контакты:

Непрочитанное сообщение wowas » 22 июл 2013, 07:33

Брать лучше из источника http://code.google.com/p/modwsgi/wiki/DownloadTheSoftware?tm=2
Только Вам похоже придется самим компилировать из исходников под 64bit.

alex-ks
Сообщения: 27
C нами: 4 года 7 мес

Непрочитанное сообщение alex-ks » 22 июл 2013, 10:40

Видимо потребуется visual studio? или можно это сделать проще?
(python и apache стоят 32 битные если это имеет значение.)

alex-ks
Сообщения: 27
C нами: 4 года 7 мес

Непрочитанное сообщение alex-ks » 23 июл 2013, 23:59

Настроил наконец. Нужно было ставить все 32 битных версий. Apache в сборке 32бит, Python 32бит (+ при установке ставить галочку "установить для всех пользователей"), mod_wsgi 32 бит(отсюда http://www.lfd.uci.edu/~gohlke/pythonlibs/#mod_wsgi ). Python ставить в дефолтную директорию C:/Python27
Последнее возможно и не обязательно.

Mercury
Сообщения: 2
C нами: 1 год 10 мес

Непрочитанное сообщение Mercury » 12 ноя 2015, 07:31

Помогите с компиляцией этого мода под современный python3.5/3.4 . Не могу разобраться.


Вернуться в «Обсуждение Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей