Не создаются домены!

Обсуждение проблем в работе программного комплекса
ar4y
Сообщения: 3
Зарегистрирован:
13 фев 2013, 13:53

Не создаются домены!

ar4y » 13 фев 2013, 14:09

Open server скачан вчера, т.е. версия последняя.
Запустил! Все просто замечательно!

Создал папки в domains новые их несколько - например, test.local.
прописал в хосте на 127.0.0.1, такой же адрес у сервера.
в настройках автомаунт папок доменов не работает, прописал вручную тоже не работает.

Особенность - компьютер в домене, установлена семерка, у меня права администратора. И даже в дополнение запуск от имени администратора не помогоает подцепить домены.
Вот что сообщает лог на попытку открыть в браузере адрес: http://test.local
[Wed Feb 13 15:02:36.600451 2013] [autoindex:error] [pid 4992:tid 724] [client 127.0.0.1:58714] AH01276: Cannot serve directory E:/OpenServer/modules/system/html/openserver/default/: No matching DirectoryIndex (index.php) found, and server-generated directory index forbidden by Options directive
при этом в папке E:\OpenServer\domains\test.local\ есть .htaccess и index.php скопированные из localhost.

браузер от имени апача сообщает:
Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.

Error 403

test.local
Apache
Какие есть идеи на счет решения данной проблемы?
Аватара пользователя
Максим
Сообщения: 5392
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 13 фев 2013, 14:58

Естественно не работает, ибо нет доступа к HOSTS файлу. А то что вы там сами в нем прописали, так это серверу до лампочки. Пока вы не дадите доступ к HOSTS файлу рабочим у вас будет только один единственный домен - localhost.
ar4y
Сообщения: 3
Зарегистрирован:
13 фев 2013, 13:53

ar4y » 13 фев 2013, 16:05

Спасибо!
Исправил путем отключения Контроля учетных записей и удалением и созданием заново hosts.
После ребута заработало!
Аватара пользователя
DelphinPRO
Сообщения: 803
Зарегистрирован:
01 фев 2012, 17:27
Откуда: Самара
Контактная информация:

DelphinPRO » 13 фев 2013, 18:07

ar4y писал(а):Исправил путем отключения Контроля учетных записей
Весьма опрометчиво с вашей стороны. Достаточно включить в настройках OpenServer опцию "Требовать права администратора". И один раз при запуске сервера подтверждать привилегии в окне UAC
ar4y
Сообщения: 3
Зарегистрирован:
13 фев 2013, 13:53

ar4y » 19 фев 2013, 14:46

Кстати, да! Так лучше. Спасибо!
Viss59
Сообщения: 7
Зарегистрирован:
04 окт 2013, 10:43

Viss59 » 04 окт 2013, 20:56

У меня такая же проблема, но удаление папки hosts и создание новой не помогает. Работает только localhost. Кто знает, в чем проблема?
Аватара пользователя
Максим
Сообщения: 5392
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 04 окт 2013, 21:00

Viss59 писал(а):У меня такая же проблема, но удаление папки hosts и создание новой не помогает. Работает только localhost. Кто знает, в чем проблема?
Видимо проблема в том, что никаких папок hosts удалять и создавать не нужно. В теме вообще речь о файле идёт, а не о папке.
Viss59
Сообщения: 7
Зарегистрирован:
04 окт 2013, 10:43

Viss59 » 04 окт 2013, 22:16

Да, вы правильно заметили, я неправильно назвал файл папкой. Но, хотелось бы ответ по сути вопроса. И, очевидно, что, если удаление файла hosts не помогло, значит проблема в другом.

Добавлено спустя 13 минут 32 секунды:
Все таки разобрался, у меня запуску мешало слово DOCS в настройках сервера (домены/автопоиск корневой папки). Удалил и все заработало.
Аватара пользователя
Максим
Сообщения: 5392
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 04 окт 2013, 22:28

Cлово DOCS в настройках сервера (домены/автопоиск корневой папки) никоем образом не влияет на создаваемость домена (именно это обсуждается в теме), а влияет лишь то, какая папка для домена станет корневой.
Viss59
Сообщения: 7
Зарегистрирован:
04 окт 2013, 10:43

Viss59 » 04 окт 2013, 22:52

Я создал по инструкции в папке domains свой домен test и он не запускался. Убил целый день. Проблема оказалась именно в том что, в настройках сервера (домены/автопоиск корневой папки) есть слово "docs", а в папке с моим сайтом есть подпапка "docs". К сожалению, нигде в документации Open Server я не нашел описание того что, наличие папки docs в папке с устанавливаемым сайтом вызывает проблему с установкой. Я надеюсь, что мое сообщение поможет сберечь время многим людям.
Ответить