Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 831 раз!

Форум

Добро пожаловать, Гость!

Php_ssh2.dll не работает!!!

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
makar3000
Сообщения: 7
C нами: 3 года 11 мес

Непрочитанное сообщение makar3000 » 23 дек 2012, 15:09

Здравствуйте, пытаюсь поставить php_ssh2.dll делаю так:

Загружаю файл в папку OpenServer\modules\php\PHP-5.3.19\ext
Редактирую php.ini добавляя в него строку extension=php_ssh2.dll
Сохраняю и запускаю сервер...

И вижу вот такую ошибку:
http://data1.floomby.com/files/share/23_12_2012/ArFvyr8kOWcrFQPlkrpA.png

После сервер останавливается.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 23 дек 2012, 18:07

Открою вам страшную тайну, которая перевернет ваше представление об устройстве этого мира и всей вселенной - расширение для PHP имеет привязку к версии PHP и к виду его сборки ( с мультипоточностю или без).

Так вот, вам нужно найти другую версию вашего расширения, чтобы оно было собрано специально для нужной вам ветки PHP (в данном случае PHP-5.3) и было собрано с поддержкой мультипоточности (Thread-safety).

makar3000
Сообщения: 7
C нами: 3 года 11 мес

Непрочитанное сообщение makar3000 » 23 дек 2012, 19:06

Максим да вы что? Правда? А я вот типо не знал!!! Я уже попробовал все! 3 версии и хренас два

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 23 дек 2012, 19:31

Если вы нашли три неподходящих версии расширения, то кто в этом виноват? В чём проблема я уже ответил выше... просто поищите ещё. Заодно убедитесь что вы активировали расширение php_openssl.dll если оно выключено (оно нужно для работы вашего ssh2).


Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей