Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 017 607 раз!

Форум

Добро пожаловать, Гость!

Взаимодействие с phpbb

Обсуждение общих вопросов связанных с программой
YarosvetSv
Сообщения: 5
C нами: 5 лет 5 мес

Непрочитанное сообщение YarosvetSv » 02 июл 2011, 15:25

Прошу помощи по взаимодействию OpenServer и форума phpbb3.
При установке которого требуется создать базу данных для форума. OpenServer имеет функцию создания таковой или требуется ещё что-то? Если не трудно, можно инструкцию небольшую. Всё что нашёл в инете, не смог реализовать. Мало знаком с базами данных. Есть простой алгоритм по запуску форума на данном сервере?
С Уважением. Заранее благодарю!

rastoman
Сообщения: 13
C нами: 5 лет 5 мес

Непрочитанное сообщение rastoman » 02 июл 2011, 15:54

чтобы создать базу нужно зайти по ссылке http://openserver/phpmyadmin
Там будет пункт создать новую базу. Пишешь имя, выбираешь кодировку например cp-1251 и создаешь. Если в форуме есть инсталлятор то в нем пишешь имя созданной базы, логин root и пароль пустой если это возможно :) иначе в архиве форума есть файл базы, который нужно залить в базу по ссылке выше через вкладку импорт

YarosvetSv
Сообщения: 5
C нами: 5 лет 5 мес

Непрочитанное сообщение YarosvetSv » 02 июл 2011, 16:27

спасибо, как только написал вопрос, сделал ещё одну попытку создать базу с помощью Mysql менеджера. потом вписал имя базы куда следует и наконец-то получилось. Просто в инете всё что находил это делалось другими способами, а так, как я только начинающий в этом вопросе, то убил день в тыканье на все кнопки связанные с DB. Всё запустилось только полчаса назад.

YarosvetSv
Сообщения: 5
C нами: 5 лет 5 мес

Непрочитанное сообщение YarosvetSv » 03 июл 2011, 11:06

Всё-таки алгоритм толком не понял, либо что-то не работает.. Решил удалить форум и поставить заново. Создал базу, в ней таблицу(пробовал двумя разными способами-через phpmyadmin и MySQLmanager). Запускаю установку форума, вбиваю имя своей базы, пользователь - root, пароль пустой и неизменно выдаёт ошибку "Не удалось подключиться к базе данных. Ниже показан текст сообщения об ошибке.
Can't connect to MySQL server on 'localhost' (10061)"

NeBox
Сообщения: 27
C нами: 5 лет 11 мес

Непрочитанное сообщение NeBox » 03 июл 2011, 11:44

вместо localhost нужно писать openserver
справка http://open-server.ru/help.html - самое верхнее.

NeBox
Сообщения: 27
C нами: 5 лет 11 мес

Непрочитанное сообщение NeBox » 03 июл 2011, 11:46

базы не обязательно постоянно создавать новые.
Если вы уже создавали БД для форума, то ее и можно использовать.
Лучше перед началом каких либо действий изучить хоть немного то, с чем работать собираетесь.
Везде есть описания и т.д... как и что устанавливать и настраивать. Нужно только прочитать.

YarosvetSv
Сообщения: 5
C нами: 5 лет 5 мес

Непрочитанное сообщение YarosvetSv » 03 июл 2011, 12:33

Благодарю всех за помощь. Читал довольно много описаний в разных местах, но стройной системы не выстроилось. Сейчас хоть какой-то скелет получился. Просто, когда что-то делаешь впервые, не знаешь, куда бросаться и куда смотреть.

YarosvetSv
Сообщения: 5
C нами: 5 лет 5 мес

Непрочитанное сообщение YarosvetSv » 04 июл 2011, 22:23

Всё отлично работает. Сервер делает своё дело.
Возникла другая проблема, когда собрался готовый форум выложить в инет. Вебсервер стал ругаться, то настройки пароля не те(решил), потом выдало, что база данных неизвестна "Unknown table engine 'InnoDB' [1286]"

Что нужно сделать, какие настройки менять, чтобы настроенный и инициализированный форум можно было выложить в инет, обходя несовместимости версий по и тп?

П.С. Вебсервер был, естественно другой.
USBWebserver


Вернуться в «Обсуждение Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и 0 гостей