Автовход в phpmyadmin

Советы и рекомендации, полезные инструкции, обмен опытом
orlov0562
Сообщения: 8
Зарегистрирован:
06 авг 2012, 10:12

Автовход в phpmyadmin

orlov0562 » 06 авг 2012, 10:20

Для того, чтобы не вводить имя/пароль от phpmyadmin каждый раз, надо сделать следующее:

1. Открываем C:\Open Server\userdata\config\phpmyadmin_config.inc.php

2. Ищем и комментируем в нем:
//$cfg['Servers'][$i]['auth_type'] = 'cookie';
3. Добавляем после закомментированной строчки:
    $cfg['Servers'][$i]['auth_type'] = 'config';
    $cfg['Servers'][$i]['user'] = 'root';
    $cfg['Servers'][$i]['password'] = '%mysqlrootpass%';
4. Перезагружаем сервер
Последний раз редактировалось orlov0562 24 янв 2013, 02:04, всего редактировалось 1 раз.
Wave
Сообщения: 39
Зарегистрирован:
14 фев 2012, 03:35

Wave » 31 дек 2012, 10:43

После обновления OS до 4.7.5 совет перестал работать.
orlov0562
Сообщения: 8
Зарегистрирован:
06 авг 2012, 10:12

orlov0562 » 24 янв 2013, 02:03

Переименован файл (по всей видимости с версии 4.7.3):
был: phpmyadmin_config.inc.php.txt
стал: phpmyadmin_config.inc.php

Т.е. теперь надо редактировать файл:
C:\Open Server\userdata\config\phpmyadmin_config.inc.php

Проверил на версии 4.7.6 - работает.

P.S. в шапке уже правильный путь
leeloo
Сообщения: 2
Зарегистрирован:
04 июл 2013, 01:16

leeloo » 11 июл 2013, 13:55

При входе в phpmyadmin открывается страница с воттаким текстом:

Warning: require_once(libraries/common.inc.php) [function.require-once]: failed to open stream: No such file or directory in N:\Server\OpenServer\modules\system\html\openserver\phpmyadmin\index.php on line 11

Fatal error: require_once() [function.require]: Failed opening required 'libraries/common.inc.php' (include_path='.;N:/Server/OpenServer/modules/php/PHP-5.2.17/;N:/Server/OpenServer/modules/php/PHP-5.2.17/PEAR') in N:\Server\OpenServer\modules\system\html\openserver\phpmyadmin\index.php on line 11

У меня не так много опыта что бы понимать что от меня хотят. Если кому не трудно буду рада за подсказку.
Zord
Сообщения: 153
Зарегистрирован:
01 сен 2012, 20:43
Откуда: Брянск

Zord » 11 июл 2013, 16:42

Не найден файл libraries/common.inc.php

Посмотрите, куда он делся
rodigy
Сообщения: 7
Зарегистрирован:
11 июл 2017, 00:20

Re: Автовход в phpmyadmin

rodigy » 31 авг 2017, 22:31

После этих настроек белый экран вместо pma, ничего не грузиться , пустой body
Аватара пользователя
jangogo
Сообщения: 7
Зарегистрирован:
13 сен 2016, 17:41

Re: Автовход в phpmyadmin

jangogo » 05 сен 2017, 15:11

ЧТо делать если не грузится?
Ответить