Open Server 4.4.6 - 4.5.6 - не работает SSI

Обсуждение проблем в работе программного комплекса
rainum
Сообщения: 3
Зарегистрирован:
17 июн 2012, 18:08

Open Server 4.4.6 - 4.5.6 - не работает SSI

rainum » 17 июн 2012, 18:12

У меня установлен 4.4.6. SSI, вроде как, должен работать из коробки. В шаблонах http все в порядке, mod_include в Apache вроде как подключен. Сервер SSI инклуды в страницах просто игнорирует. Скачал последнюю версию 4.5.6 - то же самое. Система: Windows 7 x64 Ultimate SP1.

Пожалуйста, помогите разобраться.
Аватара пользователя
Максим
Сообщения: 5364
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 17 июн 2012, 19:32

Всё там прекрасно работает.
rainum
Сообщения: 3
Зарегистрирован:
17 июн 2012, 18:08

rainum » 17 июн 2012, 20:02

В html страницу вставляю такой инклуд:
<!--#include virtual="includes/header.shtml"-->
Результата не видно.
Аватара пользователя
Максим
Сообщения: 5364
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 17 июн 2012, 20:14

Инклуды работают только в shtml страницах, а не в html куда вы добавили запись.
rainum
Сообщения: 3
Зарегистрирован:
17 июн 2012, 18:08

rainum » 17 июн 2012, 20:53

Хм, действительно заработало, спасибо! Я просто пользовался до этого денвером, а там и в html страницах все работало.
Аватара пользователя
Максим
Сообщения: 5364
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 17 июн 2012, 20:54

rainum писал(а):Хм, действительно заработало, спасибо! Я просто пользовался до этого денвером, а там и в html страницах все работало.
Настройте, что вам мешает :-)
loed71
Сообщения: 2
Зарегистрирован:
21 дек 2016, 08:41

Re: Open Server 4.4.6 - 4.5.6 - не работает SSI

loed71 » 21 дек 2016, 08:47

подскажите.. на странице shtml почему то не работает подключение вида <?include ($_SERVER['DOCUMENT_ROOT'].'/ssi/h2_1.html');?>
loed71
Сообщения: 2
Зарегистрирован:
21 дек 2016, 08:41

Re: Open Server 4.4.6 - 4.5.6 - не работает SSI

loed71 » 21 дек 2016, 10:23

а вот так вот работает <!--#include virtual="/ssi/h1_1.html"-->
т.е получается что в файле shtml не обрабатывается php код, хотя в htaccess указано AddHandler application/x-httpd-php .php .htm .html .shtml
Ответить