Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 399 350 раз!

Форум

Добро пожаловать, Гость!

Не возможно занять порт 80

Обсуждение проблем в работе программного комплекса
hrm
Сообщения: 7
C нами: 6 мес 17 дней

Непрочитанное сообщение hrm » 30 май 2017, 01:41

Добрый вечер!
Устанавливаю на локальном компьютере Open Server. При запуске получил ошибку
Изображение

Утилитой netstat определил что PID процесса равен 4
Изображение

В Диспетчере Задач узнал что это системный процесс, а именно NT Kernel & System
Изображение

Подскажите плз, как теперь освободить 80 порт.
Спасибо за помощь.

Рамиль.

Pashik
Сообщения: 95
C нами: 10 мес 17 дней

Непрочитанное сообщение Pashik » 30 май 2017, 04:41

Ответ взят с сайта Microsoft, научитесь пользоваться поисковиком :) Перейдите по пути: Панель управления -> Программы -> Включение или выключение компонентов Windows. Затем перейдите по иерархии: Найти Службы IIS -> Службы Интернета -> Безопасность и снимите галочку с "Фильтрация запросов", затем кнопка "ОК".

hrm
Сообщения: 7
C нами: 6 мес 17 дней

Непрочитанное сообщение hrm » 30 май 2017, 11:41

Спасибо Pashik. :) У меня галочка на пункте "Фильтрация запросов" не стоит. У меня вообще не стоит ни одной галочки на ветке "Службы IIS". Так что ошибка вызвана чем-то другим. Я не могу определить, что занимает 80 порт. Судя по ошибке это какая-то системная служба.

hrm
Сообщения: 7
C нами: 6 мес 17 дней

Непрочитанное сообщение hrm » 08 июн 2017, 01:33

Знатоки. Помогите плиз.

West
Сообщения: 24
C нами: 10 мес 3 дня

Непрочитанное сообщение West » 09 июн 2017, 21:43

Попробуйте запустить сервер в агрессивном режиме. Если действительно 80 порт занимает системный процесс, то у вас, скорее всего, вылетит какая-то ошибка, при попытке запуска сервера в таком режиме.

hrm
Сообщения: 7
C нами: 6 мес 17 дней

Непрочитанное сообщение hrm » 11 июн 2017, 00:40

Добрый вечер West. У меня при запуске в агрессивном режиме эта ошибка и вылетает. Не помогает даже запуск от имени Администратора. Порт занимает какая-то системная служба. Не могу найти какая.

West
Сообщения: 24
C нами: 10 мес 3 дня

Непрочитанное сообщение West » 11 июн 2017, 12:39

hrm писал(а):Добрый вечер West. У меня при запуске в агрессивном режиме эта ошибка и вылетает. Не помогает даже запуск от имени Администратора. Порт занимает какая-то системная служба. Не могу найти какая.

Из вариантов ухода от проблемы, можно еще сменить http-порт, но тогда нужно будет дописывать порт в адресной строке.

hrm
Сообщения: 7
C нами: 6 мес 17 дней

Непрочитанное сообщение hrm » 11 июн 2017, 13:10

Хочется не уйти от проблемы, а решить ее.

Ink0gnit0
Сообщения: 68
C нами: 4 года 8 мес

Непрочитанное сообщение Ink0gnit0 » 11 июн 2017, 13:49

hrm,
В командной строке, выполните следующую команду:
sc query w3svc

Если в результате присутствует строка "STATE : 4 RUNNING", выполните в командной строке (от имени администратора) следующее:
sc stop w3svc
sc config w3svc start= disabled

hrm
Сообщения: 7
C нами: 6 мес 17 дней

Непрочитанное сообщение hrm » 11 июн 2017, 18:33

Добрый день, Ink0gnit0.
При выполнении команды sc query w3svc в командной строке от имени администратора получил следующую ошибку:

[SC] EnumQueryServicesStatus: ошибка: 1060:
Указанная служба не установлена

Буду благодарен за дальнейшие указания.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость