Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 375 499 раз!

Форум

Добро пожаловать, Гость!

Проблема подключения стилей и скриптов в php

Обсуждение вопросов на другие темы связанные с веб-разработкой
fade_1
Сообщения: 2
C нами: 10 мес 3 дня

Непрочитанное сообщение fade_1 » 19 янв 2017, 15:00

Вообщем столкнулся с такой проблемой, все подключенные файлы в index.php, OS не обновляет, то есть, я написал код .js и .css запустил сервер, открыл страницу сайта, после пытаюсь изменить содержания файлов .js и .css но изменения не происходят, хотя при первом запуске подгрузил нормально, реагирует только если стили и скрипты пишутся в сам index.php, жутко бесит, помогите кто-то пожалуйста. :?:

P.S.
Использую Sublime text 3
коды подключения :
- <link rel="stylesheet" href="assets/css/style.css">
- <script src="assets/js/functions.js"></script>
.js подключен в конце body.

eandr-67
Сообщения: 54
C нами: 2 года 9 мес

Непрочитанное сообщение eandr-67 » 19 янв 2017, 21:46

Нажать в браузере Ctrl+F5.

ntzch
Сообщения: 53
C нами: 3 года 11 мес

Непрочитанное сообщение ntzch » 19 янв 2017, 21:56

Кэширование. Или отключите кэширование в вашей CMS/шаблонизаторе/фреймворке или почистите кэш браузера. Есть ещё маленький лайфхак - версионность стилей и скриптов
- <link rel="stylesheet" href="assets/css/style.css?v=1">
- <script src="assets/js/functions.js?v=1"></script>
Ну и с каждым изменением менять версию

fade_1
Сообщения: 2
C нами: 10 мес 3 дня

Непрочитанное сообщение fade_1 » 20 янв 2017, 15:33

Спасибо за ответы, вообщем, не знаю почему но в хроме не изменялись прикрепленные файлы, на другом браузере все хорошо


Вернуться в «Оффтоп и другие темы»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя