Ошибка Open Server при попытке поднять версию PHP

Обсуждение проблем в работе программного комплекса
the-solar-wind
Сообщения: 1
Зарегистрирован:
07 ноя 2016, 10:03

Ошибка Open Server при попытке поднять версию PHP

the-solar-wind » 07 ноя 2016, 10:16

Добрый день, решается такая задача:

Установлен Open Server на систему Windows XP. В настройках указана была версия php 5.4. Однако веб-проект, который делается в данный момент, требует версию 5.6. Так как некоторые директивы не исполняются, как необходимо, в условиях разных версий PHP.

При попытке поднять версию PHP, Open Server вываливает ошибку о том, что:
'Модуль PHP-5.6 может работать только на Windows 7 или выше'
.

Помогите решить данную задачу.

Заранее спасибо тем, кто даст дельный совет.
Аватара пользователя
Максим
Сообщения: 5380
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Ошибка Open Server при попытке поднять версию PHP

Максим » 07 ноя 2016, 10:59

Здесь можете найти экспериментальные сборки для WinXP SP3: https://www.apachelounge.com/viewtopic.php?t=6334
Попробуйте поставить, если понимаете как устанавливать модули в Open Server, но модуль нужно будет переименовать в PHP-5.2111 например, т.к. Open Server не даст запустить с именем PHP-5.6 на вашей версии Windows.
Ответить