Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 018 573 раза!

Форум

Добро пожаловать, Гость!

Помогите разобраться с MySQL

Обсуждение проблем в работе программного комплекса
MARRa
Сообщения: 2
C нами: 2 мес 18 дней

Непрочитанное сообщение MARRa » 17 сен 2016, 17:27

Добрый День!У меня такая проблема,я установил OpenServer,поставил модули через настройки Apache 2.4,PHP 7,MySQL 5.7 (Якобы) но когда я захожу в PhpMyAdmin то справа мне пишется то что,Версия клиента базы данных: libmysql - mysqlnd 5.0.12-dev - 20150407 - $Id: 241ae00989d1995ffcbbf63d579943635faf9972 $ Хотя должно быть 5.7.x Как исправить эту ошибку и все хорошо работало???

Аватара пользователя
Максим
Сообщения: 4872
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 17 сен 2016, 18:27

Советую вам разобраться что такое клиент и что такое сервер. Если хотите новее клиент, то включайте более новую версию PHP.

MARRa
Сообщения: 2
C нами: 2 мес 18 дней

Непрочитанное сообщение MARRa » 21 сен 2016, 10:39

Максим писал(а):Советую вам разобраться что такое клиент и что такое сервер. Если хотите новее клиент, то включайте более новую версию PHP.

Что за ответ Бредячий???У меня все модули включены новоый php 7 стоит

Аватара пользователя
Максим
Сообщения: 4872
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 21 сен 2016, 14:54

MARRa, в PHP 7 используется нативный драйвер для mysql под наименованием mysqlnd 5.0.12 что вы и видите на своём экране. Если вам не нравится название драйвера и вы считаете что он должен называться mysqlnd 5.x.x то вам необходимо обращаться к разработчикам PHP, а не сюда на форум. Я думаю они выслушают ваше предложение и пойдут вам на встречу, 100% переименуют, дерзайте.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей