Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 968 раз!

Форум

Добро пожаловать, Гость!

Установка GraphicsMagick

Обсуждение общих вопросов связанных с программой
kostr24
Сообщения: 3
C нами: 3 мес 12 дней

Непрочитанное сообщение kostr24 » 28 авг 2016, 16:54

Здравствуйте!

Я никак не могу установить GraphicsMagick в Windows 7 x64. Поставила GraphicsMagick-1.3.24, работает нормально, из командной строки gm convert запускается.
У меня php 5.4. Скачиваю класс для php, 5.4 Thread Safe (TS) x86, вот отсюда:
http://pecl.php.net/package/gmagick/1.1.6RC1/windows
распаковываю, копирую в ext, прописываю в конфигурацию extension=php_gmagick.dll
в phpinfo() появился раздел gmagick:
gmagick version 1.1.6RC1
GraphicsMagick version GraphicsMagick 1.3.19 2013-12-31 Q8 http://www.GraphicsMagick.org/

пытаюсь прочесть картинку, выдает:
Unable to access configuration file (delegates.mgk)

Как мне это исправить? Помогите, пожалуйста!

kostr24
Сообщения: 3
C нами: 3 мес 12 дней

Непрочитанное сообщение kostr24 » 29 авг 2016, 09:19

Ну подскажите пожалуйста, на старой машине в Денвере все работало, тут поставила Опенсервер и не работает. Может быть, каких-то библиотек не хватает?

kostr24
Сообщения: 3
C нами: 3 мес 12 дней

Непрочитанное сообщение kostr24 » 29 авг 2016, 09:44

Поставила и тут Денвер и старую версию GraphicsMagick как на старой машине. Работает! И в phpinfo() пишет версию правильно: GraphicsMagick 1.3.23.
А Опенсервер пишет GraphicsMagick version GraphicsMagick 1.3.19 - где он это взял? Все расширения для php скопированы из Денвера.


Вернуться в «Обсуждение Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость