Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 117 раз!

Форум

Добро пожаловать, Гость!

Долгое ожидание localhost

Обсуждение проблем в работе программного комплекса
vi161
Сообщения: 7
C нами: 8 мес 10 дней

Непрочитанное сообщение vi161 » 29 мар 2016, 12:57

CMS Magento локально очень долго загружает страницы, у полного сайта время загрузки страницы от 30 с до 90с, у почти пустого демо сайта загрузка от 3 до 15 с, причом основное время это ожидание TTFB, железо нормальное винду пробовал и 7 и 10, менял версии PHP и MySQL, пробовал кроме Open Server ещё и XAMPP, помогите разобраться, невозможно работать при таком длительном обновлении страниц. У других людей эти же сайты работают нормально, т.е. проблема не в самом коде.
Вложения
Безымянный.jpg

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 29 мар 2016, 19:31

Для начала попробуйте выполнить такой код и покажите что выводится.

<?php
$t = microtime(TRUE);

$link = mysql_connect('localhost', 'mysql', 'mysql');

echo microtime(TRUE)-$t;
?>

vi161
Сообщения: 7
C нами: 8 мес 10 дней

Непрочитанное сообщение vi161 » 29 мар 2016, 23:04

Максим писал(а):Для начала попробуйте выполнить такой код и покажите что выводится.

<?php
$t = microtime(TRUE);

$link = mysql_connect('localhost', 'mysql', 'mysql');

echo microtime(TRUE)-$t;
?>


0.0050010681152344

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 29 мар 2016, 23:14

vi161, включен ли xdebug? А защита веб-инструментов в настройках? Отключите и то и то. И надеюсь что вы не с флешки работаете.

Если всё указанное сделано - значит проблема в коде ваших скриптов и ищите ответ там.

vi161
Сообщения: 7
C нами: 8 мес 10 дней

Непрочитанное сообщение vi161 » 29 мар 2016, 23:56

Максим писал(а):vi161, включен ли xdebug? А защита веб-инструментов в настройках? Отключите и то и то. И надеюсь что вы не с флешки работаете.

Если всё указанное сделано - значит проблема в коде ваших скриптов и ищите ответ там.

Конечно не с флэшки, xdebug отключен, а где отключается защита веб-инструментов, подскажите, пожалуйста

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 29 мар 2016, 23:59

vi161, настройки программы - вкладка Сервер. Защитить сервер от внешнего доступа.

vi161
Сообщения: 7
C нами: 8 мес 10 дней

Непрочитанное сообщение vi161 » 30 мар 2016, 00:08

всё выключено, спасибо, буду разбираться в проэкте


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей