Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 050 раз!

Форум

Добро пожаловать, Гость!

WordPress на OpenServer (долгая загрузка сайта и консоли).

Обсуждение общих вопросов связанных с программой
FryDerson
Сообщения: 2
C нами: 8 мес 22 дня

Непрочитанное сообщение FryDerson » 18 мар 2016, 19:45

Проблема заключается в том, что после установки CMS (WordPress 4.4.2) на OpenServer (5.2.3) сайт долго грузится (сравнительно долго) и совсем долго отзывается админка. В частности при попытке попасть в разделы "Внешний вид", "Плагины", "Настройки" ожидание может затянуться до 15-25 секунд. Иногда помогает повторное обращение в разделу (двойное или тройной нажатие по ссылке). CMS чистая, ничего стороннего не установлено. Другие CMS (InstantCMS, Joomla, Drupal и т.д.) работают без каких-либо нареканий (отзываются моментально).

Читал всю документацию, которая устарела, так как OpenServer уже имеет иное меню и таких возможностей как отключение IPv6 в нем не предусмотрено, так что варианты решения проблемы из нее мне не помогут. Прошу знающих людей подсказать мне перечень действий (желательно подробнее, чтобы не пришлось переспрашивать), которые помогут добиться моментального отклика на сайте и в админке.

Листопад
Сообщения: 18
C нами: 1 год 11 мес
Откуда: Камчатка

Непрочитанное сообщение Листопад » 18 мар 2016, 20:41

На первой странице форума в строке поиска (длинная строка) наберите "работает как черепаха"
Из архива появится сообщение, нажмите "перейти к сообщению" и читайте, там подробно написано.

FryDerson
Сообщения: 2
C нами: 8 мес 22 дня

Непрочитанное сообщение FryDerson » 18 мар 2016, 22:04

Листопад писал(а):На первой странице форума в строке поиска (длинная строка) наберите "работает как черепаха"
Из архива появится сообщение, нажмите "перейти к сообщению" и читайте, там подробно написано.

Огромное спасибо, помогло, работает все гораздо шустрее. Я предполагал, что CMS в интернет обращается, но больше склонялся к тому, что в самом сервере запросы медленно обрабатываются. Спасибо еще раз.

Аватара пользователя
ERserver
Сообщения: 39
C нами: 1 год 4 мес

Непрочитанное сообщение ERserver » 18 мар 2016, 22:24

Попробуйте в вордпресс поставить плагины кеширования, ускорения. Защитить опенсерве от веншнего влияния. Включить в агрессивном режиме. Перезагрузить.

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 27 мар 2016, 01:44

Еще можете отключить xDebug (я не помню, включен ли он по умолчанию в ОС). Это ускорит работу php в 3-4 раза.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 27 мар 2016, 01:51

DelphinPRO писал(а):Еще можете отключить xDebug (я не помню, включен ли он по умолчанию в ОС). Это ускорит работу php в 3-4 раза.


Интересно девки пляшут... Его активность (самого расширения) никак не влияет на скорость. Если активно профилирование или отладка то это другой вопрос, но когда это включают люди понимают что будет тормозить. Никакого смысла отключать расширение нет.

Гораздо чаще у людей тормозит от неделания первого запуска (там происходит отключение приоритета ipv6 для dns, помните ошибку подключения к mysql 1 сек...) или от включения защиты веб-инструментов (2-4 раза).

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 27 мар 2016, 01:59

Максим писал(а):Его активность (самого расширения) никак не влияет на скорость.


Ну конечно :)
screenshot-20160321-125417.png

11 сек с включенным отладчиком, и меньше секунды без оного.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 27 мар 2016, 02:16

DelphinPRO, вот именно что отладка (трейс в файл или remote) и профилирование на скорость влияет, их можно отключить в конфиге. Неужели когда всё это отключено девственный xdebug замедляет ваши скрипты на 11 секунд? Какая-то фантастика :-)

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 27 мар 2016, 02:26

Не вникал в подробности :) Как нибудь посмотрю.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 27 мар 2016, 22:02

DelphinPRO, сейчас готовлю обновление, погонял ради интереса, действительно, жесть как тормозит. Раньше такого у xdebug не было. Тормозил, но не так. Хорошо что он по умолчанию отключён :-)


Вернуться в «Обсуждение Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя