Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 774 раза!

Форум

Добро пожаловать, Гость!

PHP4

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
cybd
Сообщения: 7
C нами: 4 года 10 мес

Непрочитанное сообщение cybd » 02 фев 2012, 12:50

Здравствуйте. Подскажите, пожалуйста, существует ли способ поднять на этом сервере PHP4?

musicman
Сообщения: 63
C нами: 5 лет 1 мес

Непрочитанное сообщение musicman » 02 фев 2012, 12:56

Чем старее тем лучше?) Уже на хостингах такого днем с огнем не сыщешь ;)

cybd
Сообщения: 7
C нами: 4 года 10 мес

Непрочитанное сообщение cybd » 02 фев 2012, 13:17

К сожалению, еще есть и очень много. Было бы удобно переключаться с четверки на пятерку и обратно.

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 04 фев 2012, 05:04

В след. версии может быть добавлю. Пока не известно.

Septor
Сообщения: 158
C нами: 4 года 10 мес

Непрочитанное сообщение Septor » 06 фев 2012, 14:10

Четвёрку пыха нужно не только потому что есть ещё не родивые хостеры, но и потому, что из за них приходится отлаживать скрипты на работу на 4-м - 5-м пыхе, для совместимости, так как клиент зачастую не хочет менять хостера. Так что, такое будет тоже кстати.

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 15 фев 2012, 10:21

Потестировал
PHP4 не будет ибо не существует FastCGI версии под Windows, не совместима ни с одним инструментом, несовместима с обеими версиями MySQL (поддержка только mysql 3.x.x). В общем это старьё, которому место на свалке. Похоронено рядом с PHP3, в одном склепе лежат, там и ищите :-)

cybd
Сообщения: 7
C нами: 4 года 10 мес

Непрочитанное сообщение cybd » 20 фев 2012, 10:35

Очень жаль, пых 4й очень пригодился бы, хотя бы ради отладки на локалхосте, ибо удаленно так и не получилось его настроить на виртуальной машине.
Кстати, 4й пых работает с пятым мускулем (по крайней мене на линухе) и fastcgi там тоже можно включить, используя патч (спрашивал у товарища)

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 20 фев 2012, 10:49

По вашему я этого не знаю? :-) Смешно.
Я говорил о настоящем FastCGI, а не о его работе через модуль Apache. В Open Server еще и Nginx есть, и мало ли что еще может появиться. В Linux может php4 и работает с 5-ой базой, в Windows только 3.xx - далее можно и с пятой работать, но сыпятся ошибки при использовании UTF-8(которые исправляются, но путем создания каких-то файлов и линков на диске С:\, мне это не нужно - сервер портативный).

Я уже написал - что протестировал. Многие просили прикрутить PHP4, вот я и попробовал. Т.е. реально внедрил модуль в Open Server, посмотрел как (не)работает этот труп и выкинул его подальше. Была надежда что всё будет работать хорошо, но нет. В Open Server его не будет. Обсуждать бессмысленно, думаю тему можно закрыть.

Кому очень нужно - посмотрите пожалуйста в сторону старых сборок Denwer. Там всё прекрасно работает. Я же, видимо к сожалению некоторых, внедрять в Open Server PHP 4 и MySQL 3 не собираюсь, извините. Новинки - пожалуйста, посмотрим, покрутим, внедрим если возможно. Старьё - на помойку.

Если вы маг-волшебник и сможете предоставить php 4 с работающим настоящим fastCGI под windows и с поддержкой Mysql 5, то пишите в личку! Я с удовольствием его опробую. Но думаю такой версии php не существует.


Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость