Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 016 535 раз!

Форум

Добро пожаловать, Гость!

Модули PHP7

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 10 дек 2015, 06:22

Выкладываю модули apache2.4+php7, php будет так же работать с Nginx всех версий.

Пояснения:

Apache нужен для совместимости с новым PHP (поэтому нельзя использовать уже имеющийся Apache 2.4). Поправлю это в следующей версии OS. То же самое и с названием PHP5.6-5.7 из-за проверки совместимости. Из расширений пока добавлен только Xdebug.

Как ставить:

1) Первый архив распаковать в папку с программой;
2) Выполнить установку setup.exe из второго архива;

Приятного использования!

zazu
Сообщения: 18
C нами: 1 год 10 мес

Непрочитанное сообщение zazu » 11 дек 2015, 13:13

класс, спасибо за оперативность!

DAGpro
Сообщения: 5
C нами: 1 год 9 мес

Непрочитанное сообщение DAGpro » 11 дек 2015, 19:35

При запуске жалуется на отсутствие файла VCRUNTIME140.dll.
При использовании апача+php5.7 вылазит окно с ошибкой апача и просьбой искать ошибку в инете или закрытии апача.
При использовании nginx выдает ошибку программы cgi/FastCGI.
Для решения проблемы пытался использовать команду первого запуска OS не помогло, потом скачал файл с сайта http://www.itshneg.ru/downloads/vcrunti ... mu-nelzya/ установил так же не помогло.
Компьютер на виндовс 8

Аватара пользователя
AlekseyArh
Сообщения: 3
C нами: 11 мес 23 дня
Контакты:

Непрочитанное сообщение AlekseyArh » 11 дек 2015, 20:19

Спасибо, надеялся что всё запустится, запустилось ;)

DAGpro
Сообщения: 5
C нами: 1 год 9 мес

Непрочитанное сообщение DAGpro » 11 дек 2015, 21:02

https://www.microsoft.com/ru-RU/downloa ... x?id=48145

Качал сначало x64 версию не запускался os,
потом скачал x86 версию файла и сервер запустился.

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 12 дек 2015, 00:55

DAGpro писал(а):При запуске жалуется на отсутствие файла VCRUNTIME140.dll.


Модуль предназначен только для последней версии Open Server. И если вы выполняли КАК И ПОЛОЖЕНО процедуру "Первый запуск" перед использованием, то всё будет работать.

Ваша же ошибка говорит что процедура "Первый запуск" НЕ выполнялась, либо выполнялась, но вы используете более старую версию Open Server. Сейчас добавлю в первое сообщение ссылку на нужный установщик MSVС++.

DAGpro
Сообщения: 5
C нами: 1 год 9 мес

Непрочитанное сообщение DAGpro » 12 дек 2015, 02:22

Максим, Использовал предпоследнюю версию опен-сервер, жду версию "6.0" :)

Alexander.94
Сообщения: 3
C нами: 1 год 1 мес

Непрочитанное сообщение Alexander.94 » 13 дек 2015, 13:58

Большое спасибо за сборку! Буду пробовать)

dizent
Сообщения: 23
C нами: 5 лет 6 мес

Непрочитанное сообщение dizent » 17 дек 2015, 22:42

против apache нечего не имею, но как скоро смогу работать используя nginx?

GeekHacker
Сообщения: 94
C нами: 1 год 3 мес

Непрочитанное сообщение GeekHacker » 17 дек 2015, 23:45

А что вам мешает уже его использовать? С Nginx семёрка работает.


Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей