Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 020 764 раза!

Форум

Добро пожаловать, Гость!

PHP7 RC6 + Apcache 2.4

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
ShiftedReality
Сообщения: 2
C нами: 1 год
Откуда: Kiev

Непрочитанное сообщение ShiftedReality » 11 ноя 2015, 13:46

При установке последнего релиз кандидата и запуска сервера, появляется ошибка в консоли:

"Модуль Apache-2.4 может работать только с PHP 5.5 или PHP 5.6"

Хотя это не совесм верно. Где убрать это проверку на совместимость? В Nginx такой проблемы нет, сервер поднимается без проблем.

Аватара пользователя
Максим
Сообщения: 4876
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 11 ноя 2015, 17:03

Вы не можете её убрать.

ShiftedReality
Сообщения: 2
C нами: 1 год
Откуда: Kiev

Непрочитанное сообщение ShiftedReality » 11 ноя 2015, 17:52

Спасибо за ответ. Можно ли в следующем релизе это поправить?

Аватара пользователя
Максим
Сообщения: 4876
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 11 ноя 2015, 21:22

ShiftedReality, в следующем релизе будет php7, так что проблема конечно же исчезнет.

Аватара пользователя
ISupport
Сообщения: 1
C нами: 4 дня 1 час

Непрочитанное сообщение ISupport » 04 дек 2016, 15:33

Максим писал(а):ShiftedReality, в следующем релизе будет php7, так что проблема конечно же исчезнет.


Ставлю PHP 7 в настройках "Модули"

Сбой запуска: Модуль Apache-2.4+Nginx-1.10 может работать только с PHP 5.5 или PHP 5.6

Вообщем, как мне выставить настройки, как на моем хостинге Beget

Apache: 2.4.10 MySQL: 5.7.15-9 Nginx: 1.11.6 Perl: 5.14.2 PHP: 7.0 Python: 2.7.3

Если я поставлю в настройках OpenServer\модули это Apache-PHP7+Nginx-1.10.
Будет ли это являться правильным исходя из описанного выше (beget).

P.S Объясните вкратце, x64 - что это? Если поставлю в настройкаx\модули\http с x64, будет ли это правильно?
Apache-2.4-x64+Nginx-1.10
Apache-PHP7-x64+Nginx-1.10

Заранее благодарен за ответы!

Аватара пользователя
Максим
Сообщения: 4876
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 04 дек 2016, 17:45

Ставьте Apache-PHP7+Nginx-1.10, 64 это и так из названия понятно, 64-битные модули.


Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей