Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 016 908 раз!

Форум

Добро пожаловать, Гость!

Процесс httpd.exe зависает

Обсуждение проблем в работе программного комплекса
Ashterix
Сообщения: 3
C нами: 1 год 9 мес
Откуда: Одесса

Непрочитанное сообщение Ashterix » 10 сен 2015, 12:39

Здравствуйте.

Проект на Symfony2. Несколько дней всё работало без проблем. Но сегодня с утра, без видимых причин, страницы перестали загружаться, при этом индикация загрузки крутится бесконечно, ошибки в браузер не выводятся, в логи не попадают.
Останавливаю загрузку страницы и пытаюсь удалить кеш, проводник ругается, что файл такой-то (сессия) занят каким-то процессом. Недолгий поиск указал, что процесс httpd.exe, который сожрал 50% ЦП и больше 300 Мб оперативки. После удаления процесса, файл кеша можно удалить но повторный запуск приложения приводит к тому-же результату.
Дебаг приложения показал, что оно успешно отрабатывает, но в браузер ничего не выводится.

Логи
[spoiler]

В лог apache запросов попадает такая строка
mydomen.loc: 127.0.0.1 [10/Sep/2015:12:29:23 +0300] "POST /app_dev.php/login_check HTTP/1.1" 302 445 "http://mydomen.loc/app_dev.php/" "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36"


В apache отладке следующее
[Thu Sep 10 12:28:26.434336 2015] [ssl:warn] [pid 4156:tid 224] AH01909: mydomen.loc:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:26.436336 2015] [ssl:warn] [pid 4156:tid 224] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:26.436336 2015] [ssl:warn] [pid 4156:tid 224] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:26.584344 2015] [ssl:warn] [pid 4156:tid 224] AH01909: mydomen.loc:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:26.585344 2015] [ssl:warn] [pid 4156:tid 224] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:26.586344 2015] [ssl:warn] [pid 4156:tid 224] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:26.630347 2015] [mpm_winnt:notice] [pid 4156:tid 224] AH00455: Apache/2.4.16 (Win32) OpenSSL/1.0.1p configured -- resuming normal operations
[Thu Sep 10 12:28:26.630347 2015] [mpm_winnt:notice] [pid 4156:tid 224] AH00456: Apache Lounge VC11 Server built: Jul 12 2015 10:56:48
[Thu Sep 10 12:28:26.630347 2015] [core:notice] [pid 4156:tid 224] AH00094: Command line: 'C:\\openserver\\modules\\http\\Apache-2.4\\bin\\httpd.exe -d C:/OpenServer/modules/http/Apache-2.4 -f c:\\openserver\\modules\\http\\Apache-2.4\\conf\\httpd.conf'
[Thu Sep 10 12:28:26.639347 2015] [mpm_winnt:notice] [pid 4156:tid 224] AH00418: Parent: Created child process 6196
[Thu Sep 10 12:28:27.277384 2015] [ssl:warn] [pid 6196:tid 236] AH01909: mydomen.loc:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:27.278384 2015] [ssl:warn] [pid 6196:tid 236] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:27.278384 2015] [ssl:warn] [pid 6196:tid 236] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:27.422392 2015] [ssl:warn] [pid 6196:tid 236] AH01909: mydomen.loc:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:27.423392 2015] [ssl:warn] [pid 6196:tid 236] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:27.424392 2015] [ssl:warn] [pid 6196:tid 236] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Thu Sep 10 12:28:27.469395 2015] [mpm_winnt:notice] [pid 6196:tid 236] AH00354: Child: Starting 32 worker threads.


php отладка пустая
[/spoiler]

Другие локальные домены отрабатывают нормально

Вопросы
Как отловить кто виноват php или apache?
В каком режиме работает php как модуль apache или как cgi?
Можно ли как-то изменить режим его работы, чтобы попытаться воспроизвести это состояние?

Сборка
Windows7 Professional SP1
Версия OpenSerder 5.2.2
PHP-5.6 (в php.ini правил блок Xdebug)
Apache-2.4



------------------------------------------------------


UPD: при выборе версии php 5.5 (чистые настройки) проблема пропадает
Может быть проблема в моих настройках php.ini?

[spoiler]
[Xdebug]
zend_extension="%sprogdir%/modules/php/%phpdriver%/ext/php_xdebug.dll"
;xdebug.default_enable = 1
xdebug.auto_trace = 0
xdebug.collect_includes = 1
;xdebug.collect_params = 4
;xdebug.collect_return = 1
;xdebug.collect_assignments = 1
;xdebug.collect_vars = 1
xdebug.dump.REQUEST = *
xdebug.dump.SESSION = *
xdebug.dump.SERVER = REMOTE_ADDR,REQUEST_METHOD
;xdebug.dump.COOKIE =
;xdebug.dump.FILES =
;xdebug.dump.GET =
;xdebug.dump.POST =
xdebug.dump_globals = 1
xdebug.dump_once = 1
xdebug.dump_undefined = 1
xdebug.extended_info = 1
;xdebug.file_link_format = ""
xdebug.idekey = "PHPSTORM"
;xdebug.manual_url = "http://www.php.net"
xdebug.max_nesting_level = 256
xdebug.overload_var_dump = 1
;xdebug.profiler_append = 1
xdebug.profiler_enable = 0
xdebug.profiler_enable_trigger = 0
xdebug.profiler_output_dir="%sprogdir%/userdata/temp/xdebug/"
xdebug.profiler_output_name = "cachegrind.out.%H%R"
xdebug.remote_autostart = on
xdebug.remote_enable = on
xdebug.remote_handler = "dbgp"
xdebug.remote_host = "localhost"
;xdebug.remote_log = "none"
xdebug.remote_mode = "req"
xdebug.remote_port = 9001
;xdebug.scream = 1
;xdebug.show_exception_trace = 0
;xdebug.show_local_vars = 1
;xdebug.show_mem_delta = 1
;xdebug.trace_format = 1
;xdebug.trace_options = 1
xdebug.trace_output_dir = "%sprogdir%/userdata/temp/xdebug/"
;xdebug.trace_output_name = "trace.%H%R"
xdebug.var_display_max_children = 256
;xdebug.var_display_max_data = 1024
xdebug.var_display_max_depth = 16
;xdebug.remote_cookie_expire_time = 3600

[/spoiler]


Есть идеи?

Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей