Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 020 335 раз!

Форум

Добро пожаловать, Гость!

Как обновить модули Open Server

Советы и рекомендации, полезные инструкции, обмен опытом
Аватара пользователя
Reactor
Сообщения: 14
C нами: 1 год 4 мес

Непрочитанное сообщение Reactor » 10 июл 2015, 06:20

Всем привет! Сегодня подумал как обновлять модули в Open Server, вот делюсь я с вами опытом.

1) Открываем папку Open Server, например C:\Open Server\modules\system\html\openserver\adminer.
2) Например мы хотим обновить SQLite до версии 4.2.1, у нас стоит 4.1.2, если я не ошибаюсь в версии.
3) Качаем с Оф сайта файлик adminer-4.2.1.php
4) Удаляем index.php, вставляем adminer-4.2.1.php, и переименовываем его на index.php.
5) Заходим в браузер, и пишем http://127.0.0.1/openserver/adminer/index.php. И видим что модуль обновился.

Вот собственно и всё, такими не сложными манипуляциями, мы можем обновлять модули Сервера.

P.S. У кого не получается пишем свои комменты, в эту тему. Помогу вам. Да у кого руки растут не с этого места, пожалуйста вставите, нужно ум и руки нормальные.

Спасибо за поддержку. Если есть репы, кидаем. =)

korshun1
Сообщения: 4
C нами: 1 год 2 мес

Непрочитанное сообщение korshun1 » 16 сен 2015, 16:33

спасибо, очень помогло

Аватара пользователя
Reactor
Сообщения: 14
C нами: 1 год 4 мес

Непрочитанное сообщение Reactor » 17 сен 2015, 10:59

korshun1 писал(а):спасибо, очень помогло


Всегда пожалуйста.

NekoriDes
Сообщения: 1
C нами: 10 мес 30 дней

Непрочитанное сообщение NekoriDes » 08 янв 2016, 14:03

После попытки обновить phpmyadmin таким же способом, сохраняя файл конфига, выдает ошибку, которая гласит о том, что требуется php5.5+. Тем не менее эта версия в папке php имеется. Собственно, что делать-то? Как обновится до последней версии phpmyadmin?

Аватара пользователя
Reactor
Сообщения: 14
C нами: 1 год 4 мес

Непрочитанное сообщение Reactor » 08 янв 2016, 14:12

NekoriDes писал(а):После попытки обновить phpmyadmin таким же способом, сохраняя файл конфига, выдает ошибку, которая гласит о том, что требуется php5.5+. Тем не менее эта версия в папке php имеется. Собственно, что делать-то? Как обновится до последней версии phpmyadmin?


Привет! Если Вы хотите обновить phpmyadmin, то надо смотреть путь к нему и удалить файл конфига. И занаво поставить файл php5.5... Удалить папку phpmyadmin, скачайте обновленную версию.

Аватара пользователя
Reactor
Сообщения: 14
C нами: 1 год 4 мес

Непрочитанное сообщение Reactor » 10 янв 2016, 20:40

NekoriDes писал(а):После попытки обновить phpmyadmin таким же способом, сохраняя файл конфига, выдает ошибку, которая гласит о том, что требуется php5.5+. Тем не менее эта версия в папке php имеется. Собственно, что делать-то? Как обновится до последней версии phpmyadmin?


D:\Web-Server\OpenServer\modules\system\html\openserver\phpmyadmin

Удалите папку phpmyadmin, скачайте с офф сайта... phpmyadmin... и вставте в нужный путь... вот и всё... а лучше скачать актуальную версию Open Server, там уже стоит PHP 7.0 и актуальная версия PHPMyAdmin.
Последний раз редактировалось DelphinPRO 26 янв 2016, 19:46, всего редактировалось 1 раз.
Причина: В актуальной на текущий момент версии OpenServer (5.2.3) PHP7 отсутствует!!!

mamustsm
Сообщения: 3
C нами: 1 год

Непрочитанное сообщение mamustsm » 13 янв 2016, 18:14

Доброго времени суток!
В Open Server v5.2.2 установлен модуль FTP v0.9.48 Filezilla неподдерживающий Windows XP. На Windows XP запуск сервера FTP вообще отключен.
Вопрос: Возможно обновить модуль FTP на более раньний FTP v0.9.41 Filezilla для совместимости с Windows XP, если да то как подключить его в Open Server v5.2.2?
PS. Платформа Windows Server 2003 x64 без сервера приложений, соответственно нет службы IIS и FTP. Возникла необходимость подключения FTP сервера но выяснелось что новый, установленный Open Server v5.2.2, а именно модуль FTP v0.9.48 Filezilla поддерживает только Windows (Vista, 7, 8, 8.1, 10 32/64-bit).

Аватара пользователя
Максим
Сообщения: 4875
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 13 янв 2016, 19:27

mamustsm, возможность заменить модуль есть, но Open Server всё равно не даст его настраивать, т.к. для Windows XP это не задумано (отключено).

mamustsm
Сообщения: 3
C нами: 1 год

Непрочитанное сообщение mamustsm » 13 янв 2016, 20:15

Спасибо за разъяснения, видимо придётся использовать другое решение.

SeoScope
Сообщения: 2
C нами: 1 год 3 мес

Непрочитанное сообщение SeoScope » 26 янв 2016, 18:40

Reactor писал(а):
NekoriDes писал(а):а лучше скачать актуальную версию Open Server, там уже стоит PHP 7.0 и актуальная версия PHPMyAdmin.

Вот "спасибо" вам за совет...
Так захотелось пощупать пхп 7ку, что оплатил скачку, скачал..и помянул вас матом. В актуальной версии редакции Ultimate - макс. пхп 5.6. php 7 там НЕТ.
Выкинул на ветер еще сотку, так как все 3 версии 5.23 я уже скачивал ранее.
Кстати, а что, нельзя после оплаты выбрать какие и сколько версий я хочу скачать? А то за каждую платить за скачку приходится.


Вернуться в «Полезные советы»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей