Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 020 768 раз!

Форум

Добро пожаловать, Гость!

Ошибка при установка YII2 через композер

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
KEFIR4UK
Сообщения: 7
C нами: 1 год 8 мес

Непрочитанное сообщение KEFIR4UK » 01 июн 2015, 14:54

Установил композер, далее при запуске команды

composer global require "fxp/composer-asset-plugin:~1.0.0"

выводится ошибка:
Problem 1
- guzzlehttp/streams 2.1.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
- guzzlehttp/streams 2.1.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
- guzzlehttp/streams 2.1.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
- Installation request for guzzlehttp/streams == 2.1.0.0 -> satisfiable by guzzlehttp/streams[2.1.0].

Версию пхп проверял 5.4, ставил так же 5.5 - но тоже самое.В чем проблема?

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4876
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 01 июн 2015, 16:30

KEFIR4UK, что значит то же самое. Переключите версию PHP и покажите какие ошибки вы видите. То же самое оно показывать не может.

KEFIR4UK
Сообщения: 7
C нами: 1 год 8 мес

Непрочитанное сообщение KEFIR4UK » 01 июн 2015, 17:26

Your requirements could not be resolved to an installable set of packages.

Problem 1
- guzzlehttp/streams 2.1.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
- guzzlehttp/streams 2.1.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
- guzzlehttp/streams 2.1.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
- Installation request for guzzlehttp/streams == 2.1.0.0 -> satisfiable by guzzlehttp/streams[2.1.0].


Installation failed, reverting ./composer.json to its original content.

вот что відает на php 5.6

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4876
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 01 июн 2015, 17:29

Оно не может выдавать это на php 5.6, оно выдает это на 5.3.29 потому что ваша версия PHP определяется как 5.3.29. Вы умеете работать с консолью в Open Server? Перезапускали ее после переключения модулей?

KEFIR4UK
Сообщения: 7
C нами: 1 год 8 мес

Непрочитанное сообщение KEFIR4UK » 01 июн 2015, 17:40

Конечно перезагружал, в phpinfo пишет что версия 5.6. apache 2.4 стоит.

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4876
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 01 июн 2015, 17:45

KEFIR4UK писал(а):Конечно перезагружал


Перезагружали? Вы про сервер? Нет вы не поняли, нужно закрыть саму программу консоли, и открыть ее заново из меню. Вы это сделали? Заодно почистите кэш: composer clearcache

KEFIR4UK
Сообщения: 7
C нами: 1 год 8 мес

Непрочитанное сообщение KEFIR4UK » 01 июн 2015, 17:57

Закрыл консоль и еще раз перезагрузил сервер и все заработало....вот балбес :roll:


Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей