Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 004 раза!

Форум

Добро пожаловать, Гость!

Не работают кириллические поддомены

Обсуждение проблем в работе программного комплекса
super_romeo
Сообщения: 2
C нами: 1 год 7 мес

Непрочитанное сообщение super_romeo » 05 май 2015, 20:11

Добрый день!

У меня добавлен домен: sday-lom-rf.loc
Добавлены алиасы: *.sday-lom-rf.loc

Добавлено в hosts (кодировка UTF-8):
127.0.0.1 sday-lom-rf.loc
127.0.0.1 foo.sday-lom-rf.loc
127.0.0.1 москва.sday-lom-rf.loc #и без punycode
127.0.0.1 xn--80adxhks.sday-lom-rf.loc #и в punycode

Вот так работает foo.sday-lom-rf.loc,
а вот так нет: москва.sday-lom-rf.loc.
Просто чистый экран, но не "Страница не найдена".
Вложения
2.png
1.png

super_romeo
Сообщения: 2
C нами: 1 год 7 мес

Непрочитанное сообщение super_romeo » 25 май 2015, 15:33

Ни у кого такого нет?

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 25 май 2015, 15:38

Вынужден вас расстроить, но в Windows доменные алиасы как в Linux не работают. Нельзя указать *.domen.xx для всех поддоменов, нужно создавать алиас для каждого предполагаемого поддомена, например:
poddomen1.domn.xx=>xxx.ru
poddomen2.domn.xx=>xxx.ru
poddomen3.lalala.yy=>xxx.ru

Кстати если создать запись об поддомене вручную в HOSTS файле, как это сделали вы, то даже просто с алиасами-звёздочками все будет работать, только что проверил. Так что не понятно о чем речь, проблема высосана из пальца.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и 0 гостей