Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 017 610 раз!

Форум

Добро пожаловать, Гость!

Сайт отображается некоректно

Обсуждение вопросов на другие темы связанные с веб-разработкой
Valerich
Сообщения: 3
C нами: 1 год 8 мес

Непрочитанное сообщение Valerich » 11 мар 2015, 16:48

Скачал с хоста сайт на WordPress , провел все манипуляции с БД.
Запускаю сайт на OpenServer.
Cайт отображается не корректно, вылезло куча ошибок, а в админку вообще не заходит

Deprecated: Function split() is deprecated in C:\OpenServer\domains\7age\wp-content\plugins\spgen.php on line 145

Deprecated: Assigning the return value of new by reference is deprecated in C:\OpenServer\domains\7age\wp-content\plugins\yet-another-related-posts-plugin\yarpp.php on line 32

Warning: Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\7age\wp-content\plugins\all-in-one-seo-pack\aioseop.class.php:4711) in C:\OpenServer\domains\7age\wp-includes\pluggable.php on line 881

Помогите разобраться ! Желательно подробно разжевать, так как я в этом деле не очень.

AVATOR
Сообщения: 116
C нами: 3 года 6 мес
Откуда: Ukraine

Непрочитанное сообщение AVATOR » 11 мар 2015, 19:06

в настройках Open Server-а поставь версию php 5.2 должо помочь.

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 11 мар 2015, 19:06

Включите в настройках OpenServer версию php по-старее.

Подробно тут разжевывать нечего, достаточно перевести текст ошибки в гугле (если английским не владеете)

Valerich
Сообщения: 3
C нами: 1 год 8 мес

Непрочитанное сообщение Valerich » 11 мар 2015, 19:17

поменял версию php -помогло, ошибки пропали, но в админку так и не заходит пишет:
Warning: Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\7age\wp-content\plugins\all-in-one-seo-pack\aioseop.class.php:4629) in C:\OpenServer\domains\7age\wp-includes\pluggable.php on line 881

Как с этим справиться? Помогите

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 11 мар 2015, 21:19

Обратиться к разработчику плагина all-in-one-seo-pack
Либо дождаться здесь человека, который с этим плагином работал
Ну можно еще вордпресс свежий поставить или плагин обновить.

Ну это я так, навскидку. С вордпрессом не работаю.

Аватара пользователя
duxabilii
Сообщения: 216
C нами: 5 лет 5 мес
Контакты:

Непрочитанное сообщение duxabilii » 11 мар 2015, 21:50

Не работал с данным плагинов. но скорее всего, что в файле C:\OpenServer\domains\7age\wp-content\plugins\all-in-one-seo-pack\aioseop.class.php после закрывающего тега ?> (строка 4629) есть какие-то символы (пробелы или знак абзаца). Просто удалите закрывающий тег на строке 4629 и должно помочь.

Valerich
Сообщения: 3
C нами: 1 год 8 мес

Непрочитанное сообщение Valerich » 12 мар 2015, 00:14

4627<?php if ($aioseop_options['aiosp_donate']){?>
4628
4629<tr>
4630
4631<th scope="row" style="text-align:right; vertical-align:top;">

Как видите никаких символов в строке 4629 нет

[upd=1426108585][/upd]
Обновить WordPress и сам плагин хотелось сделать на Open Server. Пока что-то никак не выходит.

lastdays
Сообщения: 9
C нами: 2 года 4 мес

Непрочитанное сообщение lastdays » 12 мар 2015, 00:49

Valerich, уважаемый, косяки WorldPress (в данном случае) не связаны с Open Server.
Исходя из выше написанного , сам плагин (код) давно устаревший и поддерживает версию модуля php < 5.3 .

Deprecated: Function split() is deprecated данный контекст означает, что функции split устаревшая, а большая часть функционала тех лет давно вырезана из новых версий php

Отсюда следует, сменить плагин на более корректный, может стоит вообще сменить WorldPress и найти что то более стоящее?

По вашей следующей ошибке можно прочитать тут.
http://cannot-modify-header-information.ru

Что бы просто убрать вывод ошибок иногда достаточно прописать в теле документа error_reporting(0); , тогда все ошибки будут скрыты от глаз людских, но саму проблему коряво-написанного модуля это не исправит.


Вернуться в «Оффтоп и другие темы»

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и 3 гостя