Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 020 339 раз!

Форум

Добро пожаловать, Гость!

Open Server + Joomla + JQuery

Обсуждение вопросов на другие темы связанные с веб-разработкой
Old Daemon
Сообщения: 7
C нами: 1 год 9 мес

Непрочитанное сообщение Old Daemon » 26 фев 2015, 18:46

Установил OpenServer 5.2.2.

Работаю с Joomla 3.х. Расширения использующие JQuery не работают...

Uncaught ReferenceError: jQuery is not defined

Сколько не пытаюсь победить - не получается. На хостинге все ОК.
Кто знает как победить ?

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 26 фев 2015, 20:17

Подключена ли jQuery? (см исходный код страницы)
Если подключена, то загружается ли по указанному пути? (см вкладку "Сеть" в инспекторе браузера)

При чем тут сервер, непонятно.

Old Daemon
Сообщения: 7
C нами: 1 год 9 мес

Непрочитанное сообщение Old Daemon » 27 фев 2015, 14:44

DelphinPRO писал(а):Подключена ли jQuery? (см исходный код страницы)
Если подключена, то загружается ли по указанному пути? (см вкладку "Сеть" в инспекторе браузера)

При чем тут сервер, непонятно.


Ну естественно грузится, на хостинге все работает без каких-либо изменений..

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 27 фев 2015, 19:51

Если бы джикверя подгружалась, то не было бы ошибки "jQuery is not defined".
Как говорится - не верю. Скрин вкладки "сеть" инспектора покажите :)

Old Daemon
Сообщения: 7
C нами: 1 год 9 мес

Непрочитанное сообщение Old Daemon » 14 мар 2015, 15:26

Вобщем мучался долго... Резюмирую. На 5.2 версии OpenServer x64 не работают 80% расширений Joomla. Либо куча ошибок, либо даже устанавливаться не хотят, либо устанавливаются но не работают как положено.

Решил ВСЕ проблемы разом, установив OpenServer 5.0. И все теперь прекрасно работает. И JQuery подгружается куда надо и как надо и вообще никаких танцев с бубнами.

AVATOR
Сообщения: 116
C нами: 3 года 6 мес
Откуда: Ukraine

Непрочитанное сообщение AVATOR » 15 мар 2015, 17:14

Версию php не пробовал менять?

Old Daemon
Сообщения: 7
C нами: 1 год 9 мес

Непрочитанное сообщение Old Daemon » 15 мар 2015, 17:47

Естественно пробовал, это первое на что я подумал. И версии PHP менял и MySql.. Выставил точно те же значения версий в OS 5.0 и все заработало, причем ради эксперимента менял версии на более низшие в пределах 5.3.х - все работает, за что Вам респект.
Видимо в версии OS x64 5.2.х (именно в ней) что-то не допилено.
Прошу не винить меня строго, может я и не прав в чем-то, но у меня эта версия отказывается работать нормально именно с Joomla и ее расширениями. Тестил на двух разных компах, чтобы не быть голословным. Поведение сервера одинаковое в точности.
На версии 5.0 - никаких проблем, там нет разделения на x86 и x64.
И работает все стабильно.

AVATOR
Сообщения: 116
C нами: 3 года 6 мес
Откуда: Ukraine

Непрочитанное сообщение AVATOR » 16 мар 2015, 11:44

Ты сейчас описываешь что тестил на разных компах ОС версию 5.0 и 5.2 но конфигурации на каких ты тестил, ты не скидуеш и нам остаётся только гадать.
Это тоже самое: когда позвонит тебе знакомый и скажет "у меня поломался комп, давай почини быстро" и ты понятия не имееш что у него не так, поскольку очнень много варианто. Так и тут на форуме хочеш что б тебе быстрей и лучше помогли пиши сразу все тут уже решим что надо, а что нет.

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 16 мар 2015, 12:53

Old Daemon, Сообщите, пожалуйста, версию Joomla и список расширений, с которыми у вас возникла проблема.
Мне дико интересно стало, я бы вечерком провел эксперименты.

[upd=1426499802][/upd]
А в идеале - копию ваших файлов (в личку), если это не коммерческая тайна.

Old Daemon
Сообщения: 7
C нами: 1 год 9 мес

Непрочитанное сообщение Old Daemon » 19 мар 2015, 10:42

Joomla 3.3.6,3.4
Расширения самые разные, например Mavik Thumbnails тот же или Shortcode Ultimate .
Давайте внесем ясность. Я о помощи никакой ни у кого не прошу. Все, что я тут пишу - для разработчиков, чтобы обратили внимание и всего лишь. Я спокойнойно вернулся к версии 5.0, в которой все работает, мне больше в принципе ничего и не требуется. Все что глючило уже и не помню, написал Вам пару расширений, которые точно помню. Мавик вроде как даже устанавливаться отказывался (либо устанавливался, но при включении плагина начисто вешал сайт - белый экран и привет и никакие танцы с бубнами не помогали, Шорткод устанавливался, но в нем не работало практически ничего, попробуйте сами.). На версии 5.0 все работает и шевелится без проблем и замечаний. За сервер разработчикам отдельное спасибо, очень нравится.
Все вышеописанное относится именно к версии OS 5.2 x64.

PS: Каких файлов вам нужна копия ???

[upd=1426751191][/upd]
AVATOR писал(а):Ты сейчас описываешь что тестил на разных компах ОС версию 5.0 и 5.2 но конфигурации на каких ты тестил, ты не скидуеш и нам остаётся только гадать.
Это тоже самое: когда позвонит тебе знакомый и скажет "у меня поломался комп, давай почини быстро" и ты понятия не имееш что у него не так, поскольку очнень много варианто. Так и тут на форуме хочеш что б тебе быстрей и лучше помогли пиши сразу все тут уже решим что надо, а что нет.


Вам так интересна конфигурация компов ??? Вам не кажется, что это к делу не имеет абсолютно никакого отношения ?


Вернуться в «Оффтоп и другие темы»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя