Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 016 092 раза!

Форум

Добро пожаловать, Гость!

Hosts: Не прописываются "ручные" домены

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
rkoss
Сообщения: 1
C нами: 1 год 10 мес

Непрочитанное сообщение rkoss » 25 янв 2015, 13:11

День добрый!

После суток разбирательств, решил-таки написать на форум.

Раньше (win7, win8) проблем никогда не было. Возможно у кого-то есть решение.

Переехал на новый комп (win 8.1), где и столкнулся с проблемой. Везде расписывается. как запускать от администратора и т.д. и все проблемы на это скидываются. Подобный себе вопрос нигде не нашел. Поэтому и прошу коллективного мнения )

ОС: Вин 8.1
Опенсервер: 5.2.2 (full)

Суть проблемы: если добавлять сайты в дефолтную папку domains и допускать автоопределение - все ок - эти домены прописываются в hosts, открываются в браузере. А вот с ручными - никак.. в hosts их нет. естественно, недоступны и в браузере.

Раньше всегда работал с "ручными" доменами, и никогда с этой проблемой не сталкивался.

Куда копать? :)

[upd=1422186792][/upd]
Еще добавлю...

Если вручную прописать в hosts эти домены, то вот что получается:

при запросе http://testweb - пустая страница
при запросе http://testweb/index.php (единственный файл в папке) выдает следующее:


Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404

testweb
01/25/15 14:49:15
Apache/2.2.29 (Win32)


кроме того судя по логам почему-то идет запрос вот сюда:
[Sun Jan 25 14:49:10 2015] [error] [client 127.0.0.1] File does not exist: C:/OpenServer/modules/system/html/default/favicon.ico
[Sun Jan 25 14:49:15 2015] [error] [client 127.0.0.1] script 'C:/OpenServer/modules/system/html/default/index.php' not found or unable to stat

в общем, я вообще запутался )) может свежий взгляд кого-нибудь поможет дать ответ

pashkasan
Сообщения: 2
C нами: 1 год 8 мес

Непрочитанное сообщение pashkasan » 03 апр 2015, 03:30

такая же история
openserver стоит на С:, домен который добавляю руками на другом диске
те что на диске С: автопоиском добавляются в hosts , тот что вручную не хочет никак
openserver 5.2.2 , apache 2.4, win7
управление доменами: ручное + автопоиск
запускаю под администратором

если управление доменами ручное - в host тоже не пишет
логи смотрел - пусто

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 25 апр 2015, 21:53

Убедитесь что для доменов выбраны папки внутри корневой папки доменов указанной в настройках. Думаю дело в этом.

pashkasan
Сообщения: 2
C нами: 1 год 8 мес

Непрочитанное сообщение pashkasan » 06 май 2015, 03:14

Максим писал(а):Убедитесь что для доменов выбраны папки внутри корневой папки доменов указанной в настройках. Думаю дело в этом.


так и сделал - перенес все на другой диск +сменил корневую папку и и включил автопоиск, а смысл тогда ручного управления доменами ? c другого диска или расположения получается нельзя домен подключить

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 06 май 2015, 07:30

pashkasan, конечно нельзя. Только из корневой папки доменов.


Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей