Псевдографика в терминале

Обсуждение общих вопросов связанных с программой
riko
Сообщения: 7
Зарегистрирован:
02 янв 2015, 22:41

Псевдографика в терминале

riko » 02 янв 2015, 22:46

Здравствуйте друзья!
Не работает псевдографика в терминале.

Подскажите как настроить терминал, что бы он показывал псевдографику?

Пробовал менять шрифты, играться с настройками - не получилось.
Вложения
2015-01-02_21-43-38.jpg
Аватара пользователя
Максим
Сообщения: 5392
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 02 янв 2015, 22:54

riko, если речь идёт о чём-либо из модуля Git, к примеру работе с терминалом через SSH (ssh клиент есть в GIT модуле), то такая проблема есть. Она уже исправлена, скоро будет обновление Open Server.
riko
Сообщения: 7
Зарегистрирован:
02 янв 2015, 22:41

riko » 02 янв 2015, 23:04

С GIT так же не работает. И с MySQL терминальным и с другими программами.
Аватара пользователя
Максим
Сообщения: 5392
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 02 янв 2015, 23:11

riko, создайте закладку в настройках Open Server на обычную Windows консоль cmd.exe и проверьте там. Сейчас, как я понимаю, вы используете ConEmu. Так же покажите любую команду, выполнив которую можно увидеть проблему, например вы говорили про MySQL... Чтобы я мог воспроизвести это у себя.
riko
Сообщения: 7
Зарегистрирован:
02 янв 2015, 22:41

riko » 02 янв 2015, 23:27

Тяжко понять проблема в самом ConEmu или в Yii2. Попробовал mysql - нормально. Попробовал PHPUnit, CodeCeption и Yii-выводы - не работают. GIT - нормально.
---
Сейчас дома, на работе ConEmu не показывает псевдографику в mysql и git (уже не уверен на 100%).
Вложения
2015-01-02_22-21-26.jpg
2015-01-02_22-19-21.jpg
riko
Сообщения: 7
Зарегистрирован:
02 янв 2015, 22:41

riko » 03 янв 2015, 22:04

Вот и Composer туда же
Вложения
12121212015-01-03_21-03-27.jpg
Аватара пользователя
Asmodey
Сообщения: 339
Зарегистрирован:
18 апр 2012, 10:33
Контактная информация:

Asmodey » 03 янв 2015, 22:11

Это не псевдографика. Это цвет.
В настройках Фичи -> включить АНСИ+Х-терминал цвета.
riko
Сообщения: 7
Зарегистрирован:
02 янв 2015, 22:41

riko » 03 янв 2015, 22:58

Asmodey, спасибо за ответ. Я использую встроеный в OpenServer ConEmu , как в нем включить цвет ?
Аватара пользователя
Asmodey
Сообщения: 339
Зарегистрирован:
18 апр 2012, 10:33
Контактная информация:

Asmodey » 03 янв 2015, 23:20

Завести сервер, вызвать консоль.
В ней: правая кнопка мыши на заголовке -> Настройки -> Фичи -> Ин-консоле настройки.

Должны стоять галочки:
1. Inject ConEmuHk
2. ANSI X3.64 / xterm 256 colors

У Вас вестимо выбрано 2, а 1 нет. И оно верещит, что поддерживает цвет, но не перехватывает вывод, чтоб покрасить (Отсюда esc-последовательности в выводе).
Оторвать оба - всё будет уныло ч/б, выбрать оба - засияет красками в меру сил.
riko
Сообщения: 7
Зарегистрирован:
02 янв 2015, 22:41

riko » 04 янв 2015, 00:05

Спасибо ребята! Вопрос решен.

Резюмируя - выкладываю скриншот рабочих настроек и как теперь выглядит САБЖ.
Вложения
2015-01-03_23-03-27.jpg
2015-01-03_23-03-04.jpg
Ответить