Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 017 609 раз!

Форум

Добро пожаловать, Гость!

Xdebug не останавливается

Обсуждение проблем в работе программного комплекса
autors
Сообщения: 2
C нами: 1 год 11 мес

Непрочитанное сообщение autors » 23 дек 2014, 16:08

Обнаружил странное поведение xdebug.

Он работает, пишет файлы в свой каталог temp,
Но не останавливается ни в начале отладки файла, ни на breakpoint.

Пробовал в двух вариантах:
OpenServer 5.2.2 + Eclipse for PHP Developers Luna Service Release 1 (4.4.1)
OpenServer 5.2.2 + NetBeans IDE 8.0.2

из чего делаю, вывод. что наверное проблема в настройках OpenServer или xdebug

Может-быть кто, сталкивался с такой проблемой и подскажет

vasya_pupkin
Сообщения: 57
C нами: 4 года 5 мес

Непрочитанное сообщение vasya_pupkin » 23 дек 2014, 18:27

Да, есть такая проблема. Сейчас скину рабочий конфиг.

[upd=1419349338][/upd]
[spoiler]
[Xdebug]
zend_extension="%sprogdir%/modules/php/%phpdriver%/ext/php_xdebug.dll"
xdebug.auto_trace = 0
;xdebug.collect_includes = 1
;xdebug.collect_params = 0
;xdebug.collect_return = 0
;xdebug.collect_vars = 0
xdebug.default_enable = 1
;xdebug.dump.SERVER = REMOTE_ADDR,REQUEST_METHOD
;xdebug.dump.SERVER = REMOTE_ADDR,REQUEST_METHOD
;xdebug.dump.COOKIE = ""
;xdebug.dump.FILES = ""
;xdebug.dump.GET = ""
;xdebug.dump.POST = ""
;xdebug.dump.REQUEST = ""
;xdebug.dump.SERVER = ""
;xdebug.dump.SESSION = ""
;xdebug.dump_globals = 1
;xdebug.dump_once = 1
;xdebug.dump_undefined = 0
;xdebug.extended_info = 1
;xdebug.file_link_format = ""
;xdebug.idekey = ""
;xdebug.manual_url = "http://www.php.net"
xdebug.max_nesting_level = 250
;xdebug.overload_var_dump = 1
;xdebug.profiler_append = 0
xdebug.profiler_enable = 0
xdebug.profiler_enable_trigger = 0
xdebug.profiler_output_dir="%sprogdir%/userdata/temp/xdebug/"
xdebug.profiler_output_name = "cachegrind.out.%H%R"
;xdebug.remote_autostart = 0
xdebug.remote_enable = 1
xdebug.remote_handler = "dbgp"
xdebug.remote_host = "localhost"
;xdebug.remote_log = "none"
;xdebug.remote_mode = "req"
xdebug.remote_port = 9000
;xdebug.show_exception_trace = 0
;xdebug.show_local_vars = 0
;xdebug.show_mem_delta = 0
;xdebug.trace_format = 0
;xdebug.trace_options = 0
xdebug.trace_output_dir = "%sprogdir%/userdata/temp/xdebug/"
;xdebug.trace_output_name = "trace.%H%R"
;xdebug.var_display_max_children = 128
;xdebug.var_display_max_data = 512
;xdebug.var_display_max_depth = 3
[/spoiler]

autors
Сообщения: 2
C нами: 1 год 11 мес

Непрочитанное сообщение autors » 23 дек 2014, 19:01

Большое спасибо - заработало

Mercury
Сообщения: 2
C нами: 1 год 10 мес

Непрочитанное сообщение Mercury » 11 янв 2015, 02:35

Столкнулся с этим в саблайме.
Папка программы по умолчанию ставится как OpenServer , но в меню ссылка "Папка с сайтами" открывает как openserver. Из-за этого при добавлении папки в проект , в сессию саблайма пишутся разные варианты пути и отсюда проблемы.

DariaSch
Сообщения: 1
C нами: 6 мес 6 дней

Непрочитанное сообщение DariaSch » 29 май 2016, 20:59

vasya_pupkin, подскажите, пожалуйста, куда нужно вставить этот код, чтоб брекпоинты начали работать?


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость