Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 020 094 раза!

Форум

Добро пожаловать, Гость!

Не открываются сайты

Обсуждение вопросов на другие темы связанные с веб-разработкой
gali
Сообщения: 8
C нами: 2 года

Непрочитанное сообщение gali » 24 ноя 2014, 11:05

Не открываются сайты. Пробовала с двумя CMS. В "моих сайтах" записи о них появились, а открывается пустая страница. Пробовала в разных браузерах. Может проблема в настройках? Что-то я упустила? Может здесь? Скрин прилагаю.
Спасибо.

[upd=1416823407][/upd]
И какие данные указывать в запросах от cms. Удалось подключиться к wordpress.
Имя базы данных?
Сервер базы данных?
Имя пользователя?
Извините за напряг. Первый раз это делаю.
Вложения
2014-11-24 11-59-06 Скриншот экрана.png
2014-11-24 11-59-06 Скриншот экрана.png (61.67 КБ) 272 просмотра

Аватара пользователя
Osvax
Сообщения: 67
C нами: 3 года 8 мес

Непрочитанное сообщение Osvax » 24 ноя 2014, 13:17

Для начала создайте базу данных через phpmyadmin хотя бы, и назначте на нее пользователя.

Далее:
gali писал(а):И какие данные указывать в запросах от cms.


Сервер базы данных = '127.0.0.1 или localhost'
Имя базы данных = 'Название базы'
Имя пользователя = 'имя пользователя если назначен или root если не назначили пользователя'
Пароль = 'Пароль назначенный пользователю или пусто если неназначали пользователя'

gali
Сообщения: 8
C нами: 2 года

Непрочитанное сообщение gali » 24 ноя 2014, 13:21

Базу создала. Сейчас попробую с Вашими подсказками. Спасибо!

[upd=1416826395][/upd]
Теперь, как я поняла, проблема с именем базы. В папке domains создала папку rootwordpress, там вся cms. Я и указала "rootwordpress". Не нравится. Я на этой CMS пробовала с купленного хостинга ставить, тоже не нравилось имя Wordpress, поставила имя_wordpress. Тогда пошло. Но в программе openservis префиксы не идут, сайт в моих сайтах не появляется. Может подскажете еще какую-нибудь cms для пробы?

[upd=1416826651][/upd]
И еще, если я пробую другую cms, остальные из domains удалять? Может это мешает?

Аватара пользователя
Osvax
Сообщения: 67
C нами: 3 года 8 мес

Непрочитанное сообщение Osvax » 24 ноя 2014, 14:04

Ничего удалять не нужно.
Базу как создавали через phpmyadmin или как? Какую ошибку выдает когда не нравится? Имя базы rootwordpress? Версия wordpress? Какие модули используете php и mysql?

gali
Сообщения: 8
C нами: 2 года

Непрочитанное сообщение gali » 24 ноя 2014, 14:19

Базу через phpmyadmin
Имя базы rootwordpress
Версия 4.0.1
Ошибку выдает (прикладываю скрин)
Модули? Где их надо использовать?
Вложения
2014-11-24 15-09-39 Скриншот экрана.png
2014-11-24 15-09-39 Скриншот экрана.png (39.84 КБ) 272 просмотра

Аватара пользователя
Osvax
Сообщения: 67
C нами: 3 года 8 мес

Непрочитанное сообщение Osvax » 24 ноя 2014, 14:39

Сейчас специально установил себе wordpress так как вы описываете, все нормально встало. У вас ошибка может в названии базы. Провретесь по буквам.

gali
Сообщения: 8
C нами: 2 года

Непрочитанное сообщение gali » 24 ноя 2014, 14:51

Представляете? Зашла! Ничего сейчас не правила, окно было открыто и просто еще раз с теми же данными попробовала зайти...и зашла. Странно! Ну и ладно, зашла. Спасибо Вам!
Кстати, пробовала Joomla, не получилось. Там какие-то особые требования? Написал, что неподходящая версия PHP. Скачала сейчас другую, а куда ее надо закачать?
Извините за нахальство! :roll:

Аватара пользователя
Osvax
Сообщения: 67
C нами: 3 года 8 мес

Непрочитанное сообщение Osvax » 24 ноя 2014, 14:55

gali писал(а):Скачала сейчас другую, а куда ее надо закачать?
Извините за нахальство! :roll:


На здоровье) Скачивать ничего не надо. На данном сайте есть руководство open-server советую изучить.
А по поводу версии, в настройках open-server имеется вкладка модули вот там и выбирайте себе подходящие версии php.

gali
Сообщения: 8
C нами: 2 года

Непрочитанное сообщение gali » 24 ноя 2014, 15:07

Спасибо большое! А по поводу инструкций, ну, я же установила (видео на ютубе нашла), а дальше думала нет ничего в инструкциях, как обычно. Все инструкции, которые я читала и смотрела по другим программам очень поверхностные (типа, "ну, а остальное, мы думаем, вы изучите сами..."). Нет, ну основное представление они дают и я их обязательно читаю (но лучше смотрю), но до меня лучше доходит, когда я сама тыкаюсь :lol:

Спасибо, еще раз, большое!


p.s. Я, кстати, два дня к вам сюда попасть не могла. Код на активацию присылают, а пароль нет :lol:

gali
Сообщения: 8
C нами: 2 года

Непрочитанное сообщение gali » 24 ноя 2014, 19:54

Добрый вечер! Загрузила Joomla, перешла на настройки, а через некоторое время не могла зайти на сайт. Т.е. в админку захожу, а на страницы сайта нет, выдает ошибку 1054. Полный текст ошибки во вкладке. Что-то в настройках пропустила?

[upd=1416850555][/upd]
Скрипт

[upd=1416856593][/upd]
Этот удалила. Создала другой. Та же история. Так же было и с wordpress. Поработали немного и отключались. Или я где-то в настройках пропускаю, или openservis
Вложения
2014-11-24 20-38-21 Скриншот экрана.png


Вернуться в «Оффтоп и другие темы»

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot] и 2 гостя