Проблема с wait_timeout в MySQL

Обсуждение проблем в работе программного комплекса
DragonBlack
Сообщения: 3
Зарегистрирован:
26 май 2014, 17:01

Проблема с wait_timeout в MySQL

DragonBlack » 26 май 2014, 17:17

Доброе время суток.

Понадобилось тут мне увеличить значение переменной wait_timeout для мускуля. Через меню открыл конфиг, нашел эту переменную, изменил значение, перезапустил сервер, но значение не поменялось.
Ради проверки поменял innodb_lock_wait_timeout - все Ок, значение изменилось. А вот значение переменной wait_timeout никак меняться не хочет.
Аватара пользователя
Максим
Сообщения: 5380
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 26 май 2014, 17:26

Прекрасно всё меняется. Убедитесь что у вас в конфиге не прописано два раза это значение (ниже к примеру), что вы указали его правильно и проверяете значение в достоверных источниках (mysql менеджер или phpmyadmin), а не в своем неком скрипте или CMS которые могут изменить это значение sql запросом в процессе выполнения.
DragonBlack
Сообщения: 3
Зарегистрирован:
26 май 2014, 17:01

DragonBlack » 26 май 2014, 18:45

Проверил. Нигде не перебивается. Приложил скрины.
Но нашел, как менять. Оказывается, переменной wait_timeout соответствует параметр interactive_timeout в конфиге.
Тогда остается вопрос: зачем в конфиге параметр wait_timeout, если он ни на что не влияет?
result.jpg
Реальные значения переменных
settings.jpg
Настройки мускуля
Аватара пользователя
Максим
Сообщения: 5380
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 26 май 2014, 18:55

interactive_timeout подхватывается вместо wait_timeout если сам wait_timeout в конфиге не указан. Так что да, можете использовать и его. Что касается самого wait_timeout то у меня данный параметр прекрасно меняется.
DragonBlack
Сообщения: 3
Зарегистрирован:
26 май 2014, 17:01

DragonBlack » 26 май 2014, 19:15

Ну, мне нет никакого резона обманывать. Имеем то, что имеем.
Ради эксперимента, вернул в конфиге дефолтное значение для wait_timeout, но оставил свое значение в interactive_timeout. Как и ожидал - в мускуле wait_timeout остался равным значению interactive_timeout.
В любом случае, проблема решена и тему можно закрывать.
Спасибо.
Ответить