Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 016 247 раз!

Форум

Добро пожаловать, Гость!

FileZilla Server в Windows XP

Обсуждение общих вопросов связанных с программой
Аватара пользователя
Dragon_Knight
Сообщения: 581
C нами: 4 года 2 мес
Контакты:

Непрочитанное сообщение Dragon_Knight » 30 апр 2014, 02:46

Открываю тему для обсуждения предстоящей версии, связи с появлением кучей вопросов.

И все вопросы связанные с CVE-2014-0160.
FileZilla Server, который используется в OS обновился и включил фикс от вышеупомянутой уязвимости, однако разработчики посчитали, что если WinXP снят с поддержки, значит у всех людей его уже нету и вырезали поддержку XP\2003, объясняя это тем, что якобы ssleay.dll, libeay.dll откомпилированный без поддержки XP\2003, хотя это полный бред, т.к. библиотеки распространяются с исходниками.
От сюда вопрос, что ждёт FileZilla Server в OS, и что вообще будет с OS, учитывая что эти библиотеки используются почти во всех модулях? Сохраниться-ли поддержка XP\2003 в OS? Будут-ли обновляться те модули, которые больше не работают на XP....

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 30 апр 2014, 11:22

Ну во первых переименовал вашу тему, поскольку главный вопрос у вас я здесь вижу всего один и касается он исключительно работы FileZilla Server в Windows XP.

Во вторых, раз поддержка Windows XP прекращена, то в Windows XP при попытке запуска сервера с включенным FTP модулем будет выдаваться стандартная ошибка несовместимости, как например сейчас для модуля PHP 5.5 и некоторых других.

Ниже отвечаю на ваши вопросы:

От сюда вопрос, что ждёт FileZilla Server в OS,


Уже ответил выше

и что вообще будет с OS, учитывая что эти библиотеки используются почти во всех модулях?


Ничего не будет, Open Server будет работать, как и работал, и развиваться дальше. Библиотеки тут не причём, проблема в прекращении поддержки XP со стороны самой программы FileZillaServer и более того, сами разработчики рекомендуют использовать DLL библиотеки от новой версии вместе со старой версией FileZillaServer совместимой с WinXP:

FileZilla Server makes use of OpenSSL. The current version 0.9.44 fixes the Heartbleed exploit that occured with OpenSSL 1.0.1f or earlier. The last working XP version 0.9.43 is vulnerable, unless you replace the libeay32.dll and ssleay32.dll files with the versions from 0.9.44. Such a 0.9.43 with SSL backport from 0.9.44 seems is safe. Version number of both DLLs must be 1.0.1.7, at least.

Сохраниться-ли поддержка XP\2003 в OS?


Конечно сохранится, пока более половины модулей не прекратит поддержку XP. Потом тупо уберу предупреждения о несовместимости и вообще сделаю невозможным запуск под XP. Установите наконец Win7 с темой оформления под XP и возрадуйтесь.

Будут-ли обновляться те модули, которые больше не работают на XP....


Конечно будут. С чего бы мне прекращать их обновлять? Потому что более новые версии модулей не поддерживают старьё в лице Windows XP? По вашему мне надо было выругаться матом и сказать ВСЁ ПОШЛИ ВСЕ В ПЕНЬ, УДАЛЯЮ PHP5.5, MONGODB и прочий ХЛАМ за прекращение поддержки XP! :mrgreen:

Аватара пользователя
Dragon_Knight
Сообщения: 581
C нами: 4 года 2 мес
Контакты:

Непрочитанное сообщение Dragon_Knight » 30 апр 2014, 22:10

Т.е. в модулях Sendmail, Apache, PHP будут использованы новые DLL-ки, которые поддерживают winXP\2003?

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 30 апр 2014, 22:20

Dragon_Knight писал(а):Т.е. в модулях Sendmail, Apache, PHP будут использованы новые DLL-ки, которые поддерживают winXP\2003?


Непонятно о чём вы спрашиваете. В папках с модулями как и всегда будут только те файлы, которые изначально идут с каждым модулем "из коробки". А поддерживает ли тот или иной модуль WinXP - это уже вопросы к его разработчикам.

Аватара пользователя
Dragon_Knight
Сообщения: 581
C нами: 4 года 2 мес
Контакты:

Непрочитанное сообщение Dragon_Knight » 01 май 2014, 01:20

Т.е. есть все шансы ожидать полной неработоспособности на winXP в следующей версии....

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 01 май 2014, 02:01

Dragon_Knight писал(а):Т.е. есть все шансы ожидать полной неработоспособности на winXP в следующей версии....


Естественно FTP модуль FileZilla с Windows XP будет несовместим, разработчики этого модуля отказались от поддержки устаревшей системы. Вы сами сообщили об этом в первом посте.

Аватара пользователя
Dragon_Knight
Сообщения: 581
C нами: 4 года 2 мес
Контакты:

Непрочитанное сообщение Dragon_Knight » 01 май 2014, 03:48

Тема не просто так называлась "Open Server 5.1" и мой вопрос имел акцент именно на это...

Т.е. есть все шансы ожидать полной неработоспособности Open Server на winXP в следующей версии....

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 01 май 2014, 10:44

Dragon_Knight писал(а):Тема не просто так называлась "Open Server 5.1" и мой вопрос имел акцент именно на это...

Т.е. есть все шансы ожидать полной неработоспособности Open Server на winXP в следующей версии....


Если для вас несовместимость FTP модуля с WinXP - это неработоспособность всего Open Server, то да, ожидайте. :mrgreen:

Аватара пользователя
Dragon_Knight
Сообщения: 581
C нами: 4 года 2 мес
Контакты:

Непрочитанное сообщение Dragon_Knight » 01 май 2014, 11:08

К чему эта клоунада? Или Вы так привыкли общаться с чайниками, что нормальные вопросы не понимаете?
Я в 4 раз перефразирую тогда....

На скриншоте видно, что SSL используется в следующих модулях: "ftp, sendmail, PHP-5.2.17, PHP-5.3.26, PHP-5.4.16, PHP-5.5.0(Win7+), wget, PostgreSQL-9.2.4, Apache-2.2.24, Apache-2.2.24+Nginx-1.4.1, Apache-2.4.4". Разработчики FileZilla Server утверждают, что откомпилированных библиотек libeay32.dll и ssleay32.dll под WindowsXP\2003 не существует.

Вопрос, их два:
1) Так-ли это.
2) Если их действительно не существует, Вы их будете компилировать сами под вышеупомянутые операционные системы, или возьмёте готовый дистрибутив модуля и не будете его модифицировать?

Добавлено спустя 9 минут 4 секунды:
У меня сейчас настроение совсем не для шуток... третий день под DDoS'ом.....
Вложения
hjghj.PNG

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 01 май 2014, 11:21

Dragon_Knight писал(а):Разработчики FileZilla Server утверждают, что откомпилированных библиотек libeay32.dll и ssleay32.dll под WindowsXP\2003 не существует.


Серьёзно? Ну тогда и Солнца с Луной не существует :mrgreen:

Dragon_Knight писал(а):1) Так-ли это.


Нет, это бред. Разработчики FileZilla такого нигде не утверждают, я даже представить не могу где вы прочитали эту чушь (дайте ссылку?). Напротив, они советуют использовать в WinXP библиотеки libeay32.dll и ssleay32.dll (которые по вашему несовместимы с XP) из комплекта с новой версией FileZilla вместе со старой версией, которая совместима с XP. И об этом я вам уже говорил ранее.

Dragon_Knight писал(а):2) Если их действительно не существует, Вы их будете компилировать сами под вышеупомянутые операционные системы, или возьмёте готовый дистрибутив модуля и не будете его модифицировать?


Я ничего не будут модифицировать и компилировать, всё везде прекрасно работает. Поддержку Windows XP прекратила ПРОГРАММА Filezilla, а не какая-то там там dll-ка типа libeay32.dll и ssleay32.dll.

Dragon_Knight писал(а):У меня сейчас настроение совсем не для шуток... третий день под DDoS'ом.....


Какое отношение имеет ваш DDOS к файлам libeay32.dll и ssleay32.dll?


Вернуться в «Обсуждение Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей