Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 016 359 раз!

Форум

Добро пожаловать, Гость!

Медленная работа сайта на win8

Обсуждение проблем в работе программного комплекса
swo
Сообщения: 4
C нами: 2 года 7 мес

Непрочитанное сообщение swo » 28 апр 2014, 11:07

Добрый день,

Проблема:
Очень медленно, порядка 1 минуты, открываются страницы сайта на win8
Причем на win7 с точно такими же настройками все летает.

Защита сервера от внешнего доступа не включена.

В чем проблема? У меня комп рабочий с win8, и ставить виртуалку для проекта так не хочу. Помогите понять почему O-S тормозит на win8.

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 28 апр 2014, 11:38

Убедитесь что вы не включили ограничение скорости во вкладке Разное настроек. А так же в том, что сервер у вас расположен НЕ на флешке. Еще могу посмотреть через тимвьювер если хотите (доступ высылайте в личку).

swo
Сообщения: 4
C нами: 2 года 7 мес

Непрочитанное сообщение swo » 28 апр 2014, 12:30

В разных все ок, проект не нафлешке, под него отдельный диск
Доступы отправлю в личку

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 28 апр 2014, 12:54

Помогло после перезагрузки?

swo
Сообщения: 4
C нами: 2 года 7 мес

Непрочитанное сообщение swo » 28 апр 2014, 13:02

да помогло, прошу прощение за глупость, не посмотрев данный фикс. Насколько я понял. в 7 IPv6 не включен, а в 8 включен по дефолту. Я правильно понял?

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 28 апр 2014, 13:09

Дело в том, я так предполагаю, что вы начали пользоваться программой не изучив руководство пользователя. Либо вам было просто не очевидно, в чём именно заключается проблема, но в этом случае необходимо было выяснить с помощью тестов, что всё дело в медленном подключении к MySQL. Согласитесь, не будут же пользователи форума разбираться в ваших скриптах где и в чём там проблема.

В руководстве пользователя про данную проблему написано и указано как её решить. Что касается Windows 7 и 8, то ipv6 по умолчанию активирован везде, просто на Win 7 вы скорее всего уже применяли патч и забыли об этом, либо ipv6 был отключен другими способами ранее.

swo
Сообщения: 4
C нами: 2 года 7 мес

Непрочитанное сообщение swo » 28 апр 2014, 13:13

Спасибо, еще раз извиняюсь за потраченное время.

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 28 апр 2014, 13:15

swo писал(а):Спасибо, еще раз извиняюсь за потраченное время.


Всегда пожалуйста, рад помочь. А время - я наоборот стараюсь помогать и на это время у меня всегда есть, хочется чтобы довольных пользователей Open Server было больше, так что время потрачено не зря, а с пользой, тем более жалкие 5 минут ;)

Baggio
Сообщения: 8
C нами: 3 года 7 мес

Непрочитанное сообщение Baggio » 29 апр 2014, 13:40

При открытии страниц в CMS Datalife Engine 10.2 на Open Server все также работает, делал все, что выше предложено - открытие страницы было около полторы секунды, стало около полсекунды - секунды.. Установлен Windows 8,1 Ent x64
Что делал:
1. в движке включил как обычно кеширование (файловый кеш), мемкеш не нашло, да и не разбирался пока.
2. отключил ipv6
3. в службах включен DNS клиент
4. Установлен антивирус NOD32 v7 предварительно весь HIPS удален, работает до сих пор в режиме обучения.
5. в файле hosts оставлен только 127.0.0.1 localhost
6. Брандмауэр выключен как служба
7. Защитник выключен

Решение - нужно для БД (базы данных, кто не понимает ;) ) вместо localhost, вписать - 127.0.0.1
Теперь сайт просто летает как и прежде :)


Open Server в файле hosts закрывает (т.е. он и так уже не активен) локалхост ipv6:
127.0.0.1 localhost
#::1 localhost
можно 6-й версии и оставить, вот так пусть будет ;) :
127.0.0.1 localhost
::1 localhost

Огромное спасибо разработчикам Open Server, что создали шикарный веб сервер :) Успехов Вам и удачи!

korkunov
Сообщения: 1
C нами: 2 года 7 мес

Непрочитанное сообщение korkunov » 30 апр 2014, 11:12

Hi.
Кхм, простите,а при чем тут ipv6 ?
Во первых, он мне сейчас нужен (доступ к блокированным сайтам, например nnm-club.me)
И если сравнить с Денвер-ом - он как-то "фиолетово" относится к ipv6.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость