Не устанавливается Owncloud

Обсуждение других вопросов связанных с веб-разработкой
susla256
Сообщения: 5
Зарегистрирован:
20 ноя 2013, 18:55

Не устанавливается Owncloud

susla256 » 22 ноя 2013, 09:43

Хочется пощупать личное облако. Скачиваю установочник ownncloud с сайта owncloud.org - owncloud-5.0.13.zip, распаковываю в папку c:\open server\domains\owncloud.loc\ Пытаюсь установить с настройками по умолчанию. не ставится. Когда ставлю в настройках более новую версию PHP, то идёт установка, в базу пишутся записи, но в итоге выскакивает ошибка, представленная на скриншоте.
Базу данных сперва создавал, через PHPmyadmin базу, затем пользователя, затем пользователю давал полные права на созданнюу базу.
листинг ошибки:
Fatal error: Call to a member function logicToPhysical() on a non-object in C:\OpenServer\domains\owncloud.loc\lib\files\storage\mappedlocal.php on line 311

Кто-нибудь запускал owncloud на open sever, чтобы всё работало?
Вложения
Ответ сервера с PHP 5.3.27.jpg
Аватара пользователя
Dragon_Knight
Сообщения: 581
Зарегистрирован:
10 сен 2012, 02:43
Контактная информация:

Dragon_Knight » 22 ноя 2013, 15:30

oC работает только на PHP 5.3+ и для полноценной установки требует много дополнений. На винде его запустить полноценно так и не удалось, а разбираться не хотелось...
susla256
Сообщения: 5
Зарегистрирован:
20 ноя 2013, 18:55

susla256 » 22 ноя 2013, 15:50

Dragon_Knight, Т.е. в виртуалбоксе можно его поставить в линукс и нормально пойдёт? Жаль, конечно, что не идёт, но переживём. Просто думал. что конфиги какие-нибудь править надо, а ни в apache, ни в phpне силён.
Спасибо, буду ковырять виртуалку.
Zord
Сообщения: 161
Зарегистрирован:
01 сен 2012, 20:43
Откуда: Брянск

Zord » 25 ноя 2013, 09:51

Судя по требованиям, он и на винде должен пойти:
    php5 (>= 5.3)
    php5-gd
    php-xml-parser
    php5-intl
Аватара пользователя
Dragon_Knight
Сообщения: 581
Зарегистрирован:
10 сен 2012, 02:43
Контактная информация:

Dragon_Knight » 25 ноя 2013, 18:46

Для полноценной работы, включая WebDAV требуется несколько расширений для апача. Их вроде нету в OS по стандарту.
susla256
Сообщения: 5
Зарегистрирован:
20 ноя 2013, 18:55

susla256 » 26 ноя 2013, 04:34

Zord, Я только понять не могу, ёш такое это " php-xml-parser и
php5-intl"
php5-gd - плагин обработки изображений, заменен на php5-gd2, он упоминается в ветке extension конфигурационного файла PHP, об остальных я в гугле описания никакого найти не могу...
Zord
Сообщения: 161
Зарегистрирован:
01 сен 2012, 20:43
Откуда: Брянск

Zord » 26 ноя 2013, 09:58

susla256 писал(а):Zord, Я только понять не могу, ёш такое это " php-xml-parser и
php5-intl"
php5-gd - плагин обработки изображений, заменен на php5-gd2, он упоминается в ветке extension конфигурационного файла PHP, об остальных я в гугле описания никакого найти не могу...
;extension=php_intl.dll - в конфиге, надо раскомментировать
extension=php_gd2.dll - в конфиге, делать ничего не надо
php-xml-parser - включено по умолчанию

Не забывайте, что необходим PHP >= 5.3.
susla256
Сообщения: 5
Зарегистрирован:
20 ноя 2013, 18:55

susla256 » 26 ноя 2013, 10:27

Zord, Пресловутая ошибка 311 вылапзит...
Пробовал apache 2.2.25 и 2.4.6
PHP все версии.
Нет в жизни счастья.

Буду использовать старую 4 версию. Она поставилась. Хотя тут:
http://www.nextofwindows.com/how-to-set ... localhost/
Сказано, что ставится 5 версия на XAMPP, хотя при установке на нём также вываливается 311 ошибка.

PS: Установил версию 4.5.13 - поставилось, завелось. В админке сказали, что можно обновиться. Распаковал дистрибутив 5 версии поверх установленной 4, зашел на страницу, после окончания процесса обновления ожидаемо получил нерабочую систему и ошибку 311.
Zord
Сообщения: 161
Зарегистрирован:
01 сен 2012, 20:43
Откуда: Брянск

Zord » 27 ноя 2013, 13:35

Что за ошибка 311?
susla256
Сообщения: 5
Зарегистрирован:
20 ноя 2013, 18:55

susla256 » 28 ноя 2013, 08:15

Zord, Извините, не 311 ошибка. а ошибка в 311 строке

Fatal error: Call to a member function logicToPhysical() on a non-object in C:\OpenServer\domains\owncloud.loc\lib\files\storage\mappedlocal.php on line 311

В PHP ничего не понимаю, поэтому ковырять без толку.
Собственно. поковырял 4 версию, не подходит из некоторых соображений, Поэтому, если не будет активности, тему можно закрыть.
Ответить