Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 117 раз!

Форум

Добро пожаловать, Гость!

Проблема с переадресацией (решено)

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
Aibent
Сообщения: 1
C нами: 3 года 1 мес

Непрочитанное сообщение Aibent » 02 ноя 2013, 08:01

Доброго времени суток.
Стоит на машине: OpenServer 4.8.9 на котором крутится сайт-заглушка; Jira на localhost:8080; Confluence на localhost:8090;
Jira и Confluence никак не завязаны на OpenServer.
Задача - осуществить проброс юзеров с team.sitename.ru на localhost:8090 и с jira.sitename.ru на localhost:8080 с помощью Apache на OpenServer.

В OpenServer прописаны поддомены, сделаны папки с ними.

Как я понял нужно в эти доменые папки закинуть файлик с виртуал хостом (в данном случаи Apache-2.4.6_vhost.conf) и отконфигурировать их.

Собственно вот теперь привожу ссылки на документации:
неофициальная
официальная

Как я понял необходимо при редактировании vhost файла использовать готовый шаблон, использую, дописываю следующий код
     ProxyRequests Off
     ProxyPreserveHost On
     <Proxy *>
        Order deny,allow
        Allow from all
     </Proxy>
     ProxyPass / http://localhost:8080/
     ProxyPassReverse / http://localhost:8080/
     <Location />
        Order allow,deny
        Allow from all
     </Location>


Зы.Зы. Разумеется вставляю перед </VirtualHost>

Перезапускаю сервер и ничего. по ссылке на jira.sitename.ru он показывает директорию папки с моим скриптом.

Что я делаю не так?

Добавлено спустя 14 часов 17 минут 34 секунды:
Не знаю что там с Apache и что я делал не верно.

Запустил через nginx, без проблем.
Всем удачи и успехов!

Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей