Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 987 раз!

Форум

Добро пожаловать, Гость!

И опять проблемы с кодировкой

Обсуждение проблем в работе программного комплекса
Jaguar™
Сообщения: 7
C нами: 5 лет 2 мес

Непрочитанное сообщение Jaguar™ » 27 сен 2011, 12:40

Здравствуйте! У меня проблема с выводом информации из БД. Английская выводиться идиально, а вот кирилица.... Смотрим приложение. Как не трудно догадаться, из БД выводилось именно 2 слово. Там было написано "Александр". Сначало вместо абракадабры были вопросительные знаки. Я воспользовался предыдущим советом (создать нового пользователя и дать ему все привелегии, кроме SUPER). Вопросительные знаки сменились на это. Большего добиться не смог ;) Выручайте =)

Jaguar™
Сообщения: 7
C нами: 5 лет 2 мес

Непрочитанное сообщение Jaguar™ » 27 сен 2011, 12:57

mysql_query ("set character_set_client='utf8'");
mysql_query ("set character_set_results='utf8'");
mysql_query ("set collation_connection='utf8_general_ci'");


после выбора БД не помогает

Jaguar™
Сообщения: 7
C нами: 5 лет 2 мес

Непрочитанное сообщение Jaguar™ » 27 сен 2011, 20:03

Админ, ау....

Аватара пользователя
duxabilii
Сообщения: 216
C нами: 5 лет 5 мес
Контакты:

Непрочитанное сообщение duxabilii » 27 сен 2011, 20:20

Jaguar™ писал(а):
mysql_query ("set character_set_client='utf8'");
mysql_query ("set character_set_results='utf8'");
mysql_query ("set collation_connection='utf8_general_ci'");


после выбора БД не помогает

mysql_query ("set names utf8");

пробовали?

Jaguar™
Сообщения: 7
C нами: 5 лет 2 мес

Непрочитанное сообщение Jaguar™ » 27 сен 2011, 21:26

Попробовал, не пашет =(

Jaguar™
Сообщения: 7
C нами: 5 лет 2 мес

Непрочитанное сообщение Jaguar™ » 01 окт 2011, 13:25

Ау! Админ, ты хоть отпишись: Знаешь, не знаешь что это такое)))

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 01 окт 2011, 16:40

В руководстве пользователя написано как устанавливать кодировку в своих скриптах. Это проверено мною лично и прекрасно работает. Если у вас не работает, то это уже видимо проблема в скрипте или с данными в базе.

NeBox
Сообщения: 27
C нами: 5 лет 11 мес

Непрочитанное сообщение NeBox » 02 окт 2011, 08:25

А файл сам в нужной кодировке?
Вариантов почему так выводится может быть много.
И сервер тут не причем. Вам нужно причину искать в скриптах.

Попробуйте так же после конекта к БД прописать mysql_set_charset('utf8');

Jaguar™
Сообщения: 7
C нами: 5 лет 2 мес

Непрочитанное сообщение Jaguar™ » 17 ноя 2011, 20:56

Проблему нашел уже давно, но вот решил отписаться =)

Нужно было просто в настройках OpSe в графе кодировка HTTP сервера (там где написано, типа не советуем менять :lol: ) сделать utf-8

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 17 ноя 2011, 21:17

Jaguar™ писал(а):Проблему нашел уже давно, но вот решил отписаться =)

Нужно было просто в настройках OpSe в графе кодировка HTTP сервера (там где написано, типа не советуем менять :lol: ) сделать utf-8

Эту кодировку типа должен выдавать ваш скрипт, а не сервер. :lol: :lol: :lol:


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей