Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 543 085 раз!

Форум

Добро пожаловать, Гость!

Меняется протокол на https в хроме.

Обсуждение проблем в работе программного комплекса
Zverush
Сообщения: 4
C нами: 1 год 3 мес

Непрочитанное сообщение Zverush » 17 дек 2017, 18:05

Не совсем уверен, что раздел правильный для данной темы, так как OpenServer вероятно и ни при чем. Но, предполагаю, что изменения в настройки придется вносить в ОS, поэтому размещаю тему здесь. Извините, если тема не соответствует разделу.

Сегодня обнаружил, что не могу зайти ни на один из моих сайтов, работающих через OS в хроме. В строке адреса http почему-то заменяется на https и страница выглядит так, как показано на скриншоте. Хром не пускает на сайт. Я не использую https, и еще вчера все работало. Вероятно это связано с обновлением хрома до версии 63, но я не уверен, обновления происходят в фоне, и последний раз когда я проверял версию, а это было около месяца назад, то версия была еще 62.
Кто-то сталкивался с подобной проблемой? Какие изменения нужно внести в OS или хром, чтобы сайты снова заработали? Спасибо.
Завтра надо начинать работу, и мне нужен это последний хром...
Вложения
https.png

Ink0gnit0
Cейчас: в сети
Сообщения: 77
C нами: 5 лет 1 мес

Непрочитанное сообщение Ink0gnit0 » 17 дек 2017, 19:58

Вариантов несколько:
1. Расширения браузера (HTTPS Everywhere и ему подобные)
2. .htaccess с закравшимся Rewrite, включённым заголовком HSTS (либо некогда включённым)
3. Конфиг выбранного веб-сервера - rewrite, HSTS, перенаправление на HTTPS

Если некогда был включён HSTS, во-первых, убедитесь, что в конфиге выбранного веб-сервера отключен/закоментирован заголовок "Strict-Transport-Security". Если включен, закоментируйте строку в шаблоне конфига и перезапустите OSPanel. Во-вторых, в chrome пройдя по ссылке chrome://net-internals/#hsts, в самом низу страницы, в поле Домен, введите наименование вашего домена - saljarstod.dev, и нажмите Удалить. Проверьте ваш сайт: http://saljarstod.dev

aaagepard
Сообщения: 5
C нами: 6 мес 10 дней

Непрочитанное сообщение aaagepard » 19 дек 2017, 13:34

Вчера после обновления хрома столкнулся с той же проблемой, все локальные сайты на OS недоступны.
Ни один из перечисленных выше вариантов не помог.
В итоге удалось нагуглить причину. Причина в домене .dev , этот домен хром сам редиректит на HTTPS

источник инфы - https://stackoverflow.com/questions/477 ... ty-invalid

Zverush
Сообщения: 4
C нами: 1 год 3 мес

Непрочитанное сообщение Zverush » 12 янв 2018, 10:43

Вот это да! Спасибо, дружище! А то я уже и на проблему забил, в лисе разрабатывал)))
Изменил домен на .local и заработало.

MyZik
Сообщения: 2
C нами: 3 мес 4 дня

Непрочитанное сообщение MyZik » 15 янв 2018, 13:56

Здравствуйте.

Не могу никак начать работу на локалке, так как браузер ругается на то, что подключение не защищено. Именно на все мои домены, кроме localhost.

Как быть?

Заранее спасибо.
Screenshot_12.png

eandr-67
Сообщения: 60
C нами: 3 года 2 мес

Непрочитанное сообщение eandr-67 » 16 янв 2018, 10:50

MyZik писал(а):Как быть?

Приподнять глаза и прочитать то, что написано на пару сообщений выше о доменах .dev

MyZik
Сообщения: 2
C нами: 3 мес 4 дня

Непрочитанное сообщение MyZik » 16 янв 2018, 11:26

eandr-67 писал(а):
MyZik писал(а):Как быть?

Приподнять глаза и прочитать то, что написано на пару сообщений выше о доменах .dev

Я это сообщение не отправлял, я отдельный топик создавал. Что за фигня? :)
// Спасибо, помогло


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость