PHP 7 + MongoDB

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
ScorpionDS
Сообщения: 2
Зарегистрирован:
18 май 2016, 20:07

PHP 7 + MongoDB

ScorpionDS » 18 май 2016, 20:15

Добрый день!

Не получается использовать PHP 7 вместе с MongoDB:
Problem 1
    - doctrine/mongodb 1.3.0 requires ext-mongo ^1.5 -> the requested PHP extension mongo is missing from your system.
    - doctrine/mongodb-odm dev-master requires doctrine/mongodb ~1.3 -> satisfiable by doctrine/mongodb[1.3.0].
    - Installation request for doctrine/mongodb-odm dev-master -> satisfiable by doctrine/mongodb-odm[dev-master].
Встроенные RockMongo тоже не работает:
To make things right, you must install php_mongo module
Понимаю, что он сообщает, что не хватает расширения, но оно есть и подключено.

Погуглил, пишут надо поставить расширение:
https://pecl.php.net/package/mongodb
но это то, что уже стоит, я подменил на новое на всякий случай, результат такой же.

Подскажите, что можно сделать?
Аватара пользователя
Максим
Сообщения: 5392
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: PHP 7 + MongoDB

Максим » 18 май 2016, 21:16

Расширения php_mongo для PHP 7 не существует, есть только php_mongodb. По вашей проблеме гугл советует выполнить: composer require alcaeus/mongo-php-adapter и только потом ставить doctrine.
ScorpionDS
Сообщения: 2
Зарегистрирован:
18 май 2016, 20:07

Re: PHP 7 + MongoDB

ScorpionDS » 18 май 2016, 22:49

Это решило проблему, спасибо.
Ответить