Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 122 раза!

Форум

Добро пожаловать, Гость!

PHP+PostgreSQL ошибки pg_connect()

Обсуждение проблем в работе программного комплекса
rean1mator
Сообщения: 4
C нами: 3 года 9 мес

Непрочитанное сообщение rean1mator » 24 фев 2013, 20:42

Доброго времени суток!
Скачал Open Server. Установил. В настройках переключил его на PHP 5.4.11 и PostgreSQL.
Для проверки работы создал пустую БД с одной таблицей, создал отдельного пользователя БД, создал себе папку для сайта и в ней уже в index.php просто написал:
pg_connect("host=localhost dbname=pay_center user=rean1mator password=1") or die('Could not connect: ' . pg_last_error());


После чего в браузере получил следующее:
Warning: pg_connect(): in C:\OpenServer\domains\spc\index.php on line 23

Warning: pg_last_error(): No PostgreSQL link opened yet in C:\OpenServer\domains\spc\index.php on line 23
Could not connect:


В чём ошибка я понять не могу.
Параметры в pg_connect() пытался передавать разными способами, но приведенный вариант мной выше был найден на php.net.
Помогите пожалуйста разобраться

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 25 фев 2013, 00:20

Я здесь как минимум не вижу указания порта, да и localhost указывается только если он существует в доменах или алиасах openserver, иначе надо указывать домен сайта.

rean1mator
Сообщения: 4
C нами: 3 года 9 мес

Непрочитанное сообщение rean1mator » 25 фев 2013, 00:47

разобрался сам. проблема была в IPv6


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя