Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 016 112 раз!

Форум

Добро пожаловать, Гость!

Не могу подключиться к MySQL

Обсуждение проблем в работе программного комплекса
LestaD-z2x
Сообщения: 1
C нами: 4 года

Непрочитанное сообщение LestaD-z2x » 28 ноя 2012, 02:17

Проблема очень бесит

Ради этой темы в форуме делаю следующие действия:
Запустил OpenServer
Открыл phpMyAdmin
Вошел от имени root
Создал БД по имени mytest
Создаю пользователя для этой базы:
Имя: myweeuser
Пароль: greatpass
Хост: localhost
Привилегии: Все поставил


Создал в базе mytest таблицу test
CREATE TABLE  `mytest`.`test` (
`id` INT NOT NULL AUTO_INCREMENT ,
`text` TEXT NOT NULL ,
PRIMARY KEY (  `id` )
) ENGINE = INNODB;


Теперь иду в папку B:\OpenServer\domains
Создаю там подпапку cam.ru
В ней файл index.php
В нем пишу такой код:
<?php

  $dblocation = "127.0.0.1";
  $dbname = "mytest";
  $dbuser = "myweeuser";
  $dbpasswd = "greatpass";

  $dbcnx = mysql_connect($dblocation, $dbuser, $dbpasswd);
  if (!$dbcnx)
  {
    echo "<p>К сожалению, не доступен сервер mySQL</p>";
    exit();
  }
  if (!mysql_select_db($dbname,$dbcnx) )
  {
    echo "<p>К сожалению, не доступна база данных</p>";
    exit();
  }
  $ver = mysql_query("SELECT VERSION()");
  if(!$ver)
  {
    echo "<p>Ошибка в запросе</p>";
    exit();
  }
  echo mysql_result($ver, 0);

Специально не ставил знаки @ перед функциями mysql_

Перезагружаю OpenServer... ошибок нет
Теперь в браузере открываю http://cam.ru/
И что я вижу:
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'myweeuser'@'127.0.0.1' (using password: YES) in B:\OpenServer\domains\cam.ru\index.php on line 8
К сожалению, не доступен сервер mySQL


Но! Если поставить пользователя root и убрать пароль
Всё отлично, отображается версия MySQL

Оговорка: Этот же код тестировался на Denwer, всё работает
Говорю сразу, на время тестирования этого кода, я отключал Denwer и после этого запускал OpenServer
Даже для уверенности выходил и входил в систему заново

У меня стоит Windows 8 x64 и последняя версия OpenServer

Очень жду помощи, потому что я создаю веб-приложение, а денвер по каким-то причинам работает медленно, то есть страница перед тем как отобразиться просто грузится какое-то время, а потом резво отображается. Когда у меня стояла Win7 всё было норм с тем же денвером и тем же проектом. У моего знакомого такая же лабуда на Ноуте, а на стационаре все отлично


Заранее благодарен!

sergey
Сообщения: 1
C нами: 4 года

Непрочитанное сообщение sergey » 02 дек 2012, 15:41

Такая же проблема и у меня, с той-лишь разницей, что у меня win 7 на стационаре. Все остальные действия аналогичны. Хотелось бы услышать хотя-бы предположения Максима. :?:

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 02 дек 2012, 17:31

Тусуйтесь тут: viewtopic.php?f=6&t=656&p=4540#p4540

тема закрыта


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость