Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 018 103 раза!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Archon80
Сообщения: 1
C нами: 4 мес 4 дня

Непрочитанное сообщение Archon80 » 01 авг 2016, 16:46

Здравствуйте.
Возникла следующая проблема: не запускается OpenServer с базой PosrgreSQL.
Если не подключать модуль PosrgreSQL, OpenServer работает нормально.
Пробовал разные варианты конфигурации модулей, в том числе разные версии PosrgreSQL - результат всегда один.

Что происходит: некоторое время сервер пытается запуститься, затем спустя несколько секунд отключается.

Содержимое файла OpenServer\userdata\profiles\Default.ini
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=1
postgresql_log=1
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.4"
httpdriver="Apache-2.2"
mysql_driver=none
pg_driver="PostgreSQL-9.2"
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=1
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=0
favorite=0
showswitch=1
debugmode=0
stext=1
sbrowser=1
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser="%realprogdir%\progs\_Internet\GoogleChromePortable\GoogleChromePortable.exe"
textred="%realprogdir%\progs\_Office\Notepad++\notepad++.exe"
filebrowser=""
sfilebrowser=0
maxrequests=0
folders=""

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""


Параметры системы: Windows 7, домашняя базовая версия, Service Pack 1, 64-разрядная.
Учетная запись администратора.
Антивирус - доктор Веб, никаких оповещений не выводил.
Фаервол - только встроенный от Винды.

Содержимое вкладки основного лога:
2016-08-01 16:38:38  Начало процедуры запуска сервера
2016-08-01 16:38:39  Обновление Hosts файла
2016-08-01 16:38:39  Обновление конфигурации Sendmail
2016-08-01 16:38:39  Обновление конфигурации PHP-5.4
2016-08-01 16:38:39  Обновление конфигурации PHPPgAdmin
2016-08-01 16:38:39  Обновление конфигурации Apache-2.2
2016-08-01 16:38:39  Запуск PostgreSQL-9.2
2016-08-01 16:38:39  Запуск Apache-2.2
2016-08-01 16:38:39  Проверка состояния сервера
2016-08-01 16:39:14  Не удалось запустить PostgreSQL-9.2
2016-08-01 16:39:14  Сбой запуска!
2016-08-01 16:39:14  --------------------------------------------
2016-08-01 16:39:14  Начало процедуры остановки сервера
2016-08-01 16:39:14  Остановка системных модулей
2016-08-01 16:39:14  Отключение виртуального диска
2016-08-01 16:39:14  Сервер успешно остановлен за 0,687 секунд!


Лог Апача:
[Mon Aug 01 16:38:40 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Aug 01 16:38:40 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Aug 01 16:38:40 2016] [notice] Apache/2.2.31 (Win32) mod_ssl/2.2.31 OpenSSL/1.0.1p configured -- resuming normal operations
[Mon Aug 01 16:38:40 2016] [notice] Server built: Jul 16 2015 11:30:50
[Mon Aug 01 16:38:40 2016] [notice] Parent: Created child process 372
[Mon Aug 01 16:38:40 2016] [notice] Disabled use of AcceptEx() WinSock2 API
[Mon Aug 01 16:38:40 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Aug 01 16:38:41 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Aug 01 16:38:41 2016] [notice] Child 372: Child process is running
[Mon Aug 01 16:38:41 2016] [notice] Child 372: Acquired the start mutex.
[Mon Aug 01 16:38:41 2016] [notice] Child 372: Starting 32 worker threads.
[Mon Aug 01 16:38:41 2016] [notice] Child 372: Listening on port 443.
[Mon Aug 01 16:38:41 2016] [notice] Child 372: Listening on port 80.


Лог PostgreSQL пуст.

Поскольку в главном логе не выводится причина проблемы, не знаю даже, в каком направлении смотреть и что гуглить.

Amandi
Сообщения: 1
C нами: 3 мес 17 дней

Непрочитанное сообщение Amandi » 19 авг 2016, 10:27

Привет. В чем может быть проблема. После запуска сервера стало появляться сообщение о том, что отсутствует файл MSVCR110.dll. А после того, как хочу открыть сайт или phpMyAdmin, появляется ошибка "504 Gateway Time-out". Как исправить проблему, помогите пожалуйста?!

deert
Сообщения: 1
C нами: 3 мес 17 дней

Непрочитанное сообщение deert » 19 авг 2016, 10:54

Добрый день.
Скачал архив Open Server 5.2.5 Ultimate с сайта. При запуске файла Open Server x64.exe появляется такая ошибка:

Сигнатура проблемы:
Имя события проблемы: APPCRASH
Имя приложения: Open Server x64.exe
Версия приложения: 5.2.2.0
Отметка времени приложения: 54900de0
Имя модуля с ошибкой: Open Server x64.exe
Версия модуля с ошибкой: 5.2.2.0
Отметка времени модуля с ошибкой: 54900de0
Код исключения: c0000005
Смещение исключения: 000000000000cc59
Версия ОС: 6.1.7601.2.1.0.256.1
Код языка: 1049
Дополнительные сведения 1: 45dd
Дополнительные сведения 2: 45dd43b634d51d8d2de493dc557cad64
Дополнительные сведения 3: 2121
Дополнительные сведения 4: 21216272d12a743338249ba4e80ee686

Ознакомьтесь с заявлением о конфиденциальности в Интернете:
http://go.microsoft.com/fwlink/?linkid= ... cid=0x0419

Если заявление о конфиденциальности в Интернете недоступно, ознакомьтесь с его локальным вариантом:
C:\Windows\system32\ru-RU\erofflps.txt


ОС : Windows 7 x64

Котович
Сообщения: 1
C нами: 3 мес 17 дней

Непрочитанное сообщение Котович » 19 авг 2016, 13:26

не работает библиотека LibGD . подскажите что делать пожалуйста.

PaRtiZzaN
Сообщения: 1
C нами: 3 мес 7 дней

Непрочитанное сообщение PaRtiZzaN » 29 авг 2016, 19:27

Перестал запускаться MySQL. В бд могу зайти но сайты не работают. Перезапускал, переустанавливал, перезагружался. Ничего не помогло.

dusk
Сообщения: 2
C нами: 3 мес 6 дней

Непрочитанное сообщение dusk » 30 авг 2016, 17:41

Добрый день. Помогите пожалуйста разобраться.

Установил Open Server
запустил и вроде все настроил как было описано во многих темах и статьях.
ну там localhost и антивирь чтоб пропускал и из под админа...

создал попку с названием сайта. все подхватилось... но !

нет доступа к сайту из мира. локально открывается а из мира нету.
до этого стоял вамп. сайт работал. все было хорошо. теперь голяк.

и еще при нажатии в меню программы на всякие функции типа myadmin или еще чего - ничего не происходит. совсем. нажал и ничего. не могу даже зайти таблицу новую создать.

подскажите может какая беда была при установке или не подходит моя старенькая windows server 2003 ?? не знаю уже куда копать. устал читать.

спасибо.

Кот_Лета
Сообщения: 2
C нами: 3 мес 3 дня

Непрочитанное сообщение Кот_Лета » 02 сен 2016, 16:36

На работе понадобился быстрый джентельменский набор. Времени ставить и конфигурить аппачку, пхп и мускул под винду не было. Выбор пал на Ваш сервер.

Приятное меню, всё логично, кроме одного пункта.

Как запустить сервер по локальной сети?
Сайт по ссылке localhost работает.
Сайт по ссылке айпи (вида 192.168.ххх.ххх) с соседнего компа не виден.

В мануале читаю строки: Работа с внешними сетями

Open Server может работать в локальных сетях и сети Интернет как веб-сервер. Для работы в сети Интернет необходим статический(белый) IP адрес. Чтобы открыть доступ к серверу извне необходимо указать * в качестве IP адреса в настройках Open Server, в этом случае доступ откроется сразу для всех сетей, к которым подключён ваш компьютер. Если вы хотите открыть доступ только для одной конкретной сети (например локальной), то укажите в настройках программы IP адрес выданный вашему компьютеру в этой сети.

ГДЕ в настройках программы указать мой айпи? вида 192.168.ххх.ххх ?

Почему нужны такие танцы с бубном? Хочется поставить набор, закинуть несколько статичных страничек в htpdocs и забыть об этом.

Аватара пользователя
Максим
Сообщения: 4872
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 03 сен 2016, 09:37

Кот_Лета писал(а):ГДЕ в настройках программы указать мой айпи? вида 192.168.ххх.ххх ?


Хм, ну откройте настройки программы, полистайте вкладки и посмотрите на опции. Если сразу не найдёте, то смотрите еще 5-10-20 раз, вдумчивее, внимательнее.

Аватара пользователя
Максим
Сообщения: 4872
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 03 сен 2016, 09:38

dusk, ваша винда не подходит, вы не настраивали Open Server на работу на внешних IP, при нажатии ничего не происходит поскольку ни на вашей машине ни в настройках Open Server не настроен браузер по умолчанию.

Кот_Лета
Сообщения: 2
C нами: 3 мес 3 дня

Непрочитанное сообщение Кот_Лета » 05 сен 2016, 09:50

Максим писал(а):
Кот_Лета писал(а):ГДЕ в настройках программы указать мой айпи? вида 192.168.ххх.ххх ?


Хм, ну откройте настройки программы, полистайте вкладки и посмотрите на опции. Если сразу не найдёте, то смотрите еще 5-10-20 раз, вдумчивее, внимательнее.


Вбиваю свой айпи в настройках и сыпется ошибка:

2016-09-05 09:49:49 --------------------------------------------
2016-09-05 09:49:49 Начало процедуры запуска сервера
2016-09-05 09:49:49 Несовместимость конфигурации: домен/алиас localhost можно использовать только с IP-адресом 127.0.0.1
2016-09-05 09:49:49 Сбой запуска!


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя