Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 018 587 раз!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
CHADREX
Сообщения: 2
C нами: 1 год 6 мес

Непрочитанное сообщение CHADREX » 14 май 2015, 23:32

сегодня перестал запускаться open server, причина непонятная. Это появлось после перезагрузки, с ним ничего не делал даже. Логи программы показывают следующее:

2015-05-14 21:38:07 --------------------------------------------
2015-05-14 21:38:07 Начало процедуры запуска сервера
2015-05-14 21:38:07 Создание виртуального диска
2015-05-14 21:38:07 Обновление Hosts файла
2015-05-14 21:38:07 Обновление конфигурации MySQL-5.5.37
2015-05-14 21:38:07 Обновление конфигурации Sendmail
2015-05-14 21:38:07 Обновление конфигурации PHP-5.4.26
2015-05-14 21:38:07 Обновление конфигурации PHPMyAdmin
2015-05-14 21:38:07 Обновление конфигурации Apache-2.2.27
2015-05-14 21:38:07 Запуск MySQL-5.5.37
2015-05-14 21:38:07 Запуск Apache-2.2.27
2015-05-14 21:38:07 Проверка состояния сервера
2015-05-14 21:38:19 Не удалось запустить MySQL-5.5.37
2015-05-14 21:38:19 Сбой запуска!
2015-05-14 21:38:19 --------------------------------------------
2015-05-14 21:38:19 Начало процедуры остановки сервера
2015-05-14 21:38:19 Остановка системных модулей
2015-05-14 21:38:19 Отключение виртуального диска
2015-05-14 21:38:19 Веб-сервер успешно остановлен!


Логи самого модуля mysql:

150514 21:38:07 [Note] Plugin 'FEDERATED' is disabled.
150514 21:38:07 InnoDB: The InnoDB memory heap is disabled
150514 21:38:07 InnoDB: Mutexes and rw_locks use Windows interlocked functions
150514 21:38:07 InnoDB: Compressed tables use zlib 1.2.3
150514 21:38:07 InnoDB: Initializing buffer pool, size = 20.0M
150514 21:38:07 InnoDB: Completed initialization of buffer pool
150514 21:38:07 InnoDB: highest supported file format is Barracuda.
150514 21:38:08 InnoDB: Waiting for the background threads to start
150514 21:38:09 InnoDB: 5.5.37 started; log sequence number 59945642
150514 21:38:09 [ERROR] I/O error reading the header from the binary log, errno=175, io cache code=0
150514 21:38:09 [ERROR] I/O error reading the header from the binary log
150514 21:38:09 [ERROR] Can't init tc log
150514 21:38:09 [ERROR] Aborting

150514 21:38:09 InnoDB: Starting shutdown...
150514 21:38:09 InnoDB: Shutdown completed; log sequence number 59945642
150514 21:38:09 [Note] W:\modules\database\MySQL-5.5.37\bin\mysqld.exe: Shutdown complete


После удаления файлов ib_logfile0 и ib_logfile1 (так мне посоветjвали) стало показывать следующее:

150514 23:28:07 [Note] Plugin 'FEDERATED' is disabled.
150514 23:28:07 InnoDB: The InnoDB memory heap is disabled
150514 23:28:07 InnoDB: Mutexes and rw_locks use Windows interlocked functions
150514 23:28:07 InnoDB: Compressed tables use zlib 1.2.3
150514 23:28:07 InnoDB: Initializing buffer pool, size = 20.0M
150514 23:28:07 InnoDB: Completed initialization of buffer pool
150514 23:28:07 InnoDB: highest supported file format is Barracuda.
150514 23:28:09 InnoDB: Waiting for the background threads to start
150514 23:28:10 InnoDB: 5.5.37 started; log sequence number 50333718
150514 23:28:10 [Note] Recovering after a crash using mysql-bin
150514 23:28:10 [Note] Starting crash recovery...
150514 23:28:10 [Note] Crash recovery finished.
150514 23:28:10 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
150514 23:28:10 [Note] - '127.0.0.1' resolves to '127.0.0.1';
150514 23:28:10 [Note] Server socket created on IP: '127.0.0.1'.
150514 23:28:10 [ERROR] W:\modules\database\MySQL-5.5.37\bin\mysqld.exe: Incorrect information in file: '.\mysql\user.frm'
150514 23:28:10 [ERROR] Fatal error: Can't open and lock privilege tables: Incorrect information in file: '.\mysql\user.frm'

Что можно сделать? Попробовал перенести данные на более новую версию, но там с базой не соединяет нормально. Переносил папку MySQL-5.5.37 целиком из папка userdata.

Также пробовал скопировать из старого бекапа файл user.frm, с этим сервер запустился, однако на сайте база не подключилась, а в самом phpmyadmin жуть какая-то.

Аватара пользователя
Максим
Сообщения: 4872
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 15 май 2015, 12:30

CHADREX, место на диске закончилось или диск посыпался.

CHADREX
Сообщения: 2
C нами: 1 год 6 мес

Непрочитанное сообщение CHADREX » 16 май 2015, 21:06

Максим писал(а):CHADREX, место на диске закончилось или диск посыпался.


Быть такого не может. У меня установлено несколько локалок, и все они прекрсно работают. Ну за исключением того о котором я сейчас пишу. Может есть инфа о том как правильно перенести на другую локалку? База данных то целая.

Аватара пользователя
Rolles217
Сообщения: 3
C нами: 1 год 11 мес
Откуда: Тольятти

Непрочитанное сообщение Rolles217 » 18 май 2015, 14:16

Здравствуйте)
та же проблема как и в посте выше, месяц назад все работало, больше ничего не трогал, новых программ вроде не устанавливал, настройки сервера по умолчанию, но если у domjik все решилось убрав домены второго уровня, то у меня таких нету.. не пойму в чем проблема, новые логи не создались..
Вложения
2015-05-18 14-56-43 Скриншот экрана.png

Аватара пользователя
Максим
Сообщения: 4872
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 24 май 2015, 01:27

CHADREX, прошу прощения, невнимательно прочитал ваш пост. У вас некорректный файл user.frm': Incorrect information in file: '.\mysql\user.frm'

Было подумал что у вас диск посыпался, оказалось что вы сами меняли этот файл. Верните стандартные файлы в папку с данными по маске (user.* MYD MYI FRM) и всё должно заработать как положено.

[upd=1432420142][/upd]
Rolles217, обратитесь ко мне в личку и скиньте данные доступа к тимвьюверу когда я буду в сети, только так можно будет вам помочь. Думаю всё поправим, не переживайте.

plotpam
Сообщения: 1
C нами: 1 год 6 мес

Непрочитанное сообщение plotpam » 24 май 2015, 15:28

"После старта программы вы увидите красный флажок в трее Windows" Как обойтись без этого, доступ к трею заблокирован?

ser014
Сообщения: 1
C нами: 1 год 6 мес

Непрочитанное сообщение ser014 » 24 май 2015, 17:24

Не входить в PHPMyadmin пишет Connection refused: 127.0.0.1:80 как быть? почему доступ закрыть?

Вася
Сообщения: 1
C нами: 1 год 5 мес

Непрочитанное сообщение Вася » 08 июн 2015, 17:53

Всем привет! у меня такая ошибка:
Изображение

Изображение

kartavenko
Сообщения: 2
C нами: 1 год 5 мес

Непрочитанное сообщение kartavenko » 23 июн 2015, 18:52

Добрый день,
Спасибо за сборку. Судя по комплектации, это стоило немалого труда.

Однако воспользоваться, увы, не получается.
Система - XP SP3, всё, что нужно - отключено (самая нижняя картинка), я - администратор.
Через пару секунд после запуска "Open Server x86.exe" появляется сообщение об ошибке (вторая снизу картинка, с развёрнутыми ссылками).
Позакрывав это всё, вижу следующее окошко.
И, наконец, понеслась... На верхней картинке видно, что "Runtime error" плодятся :)

Поиск по форуму дал 2 причины - некорректное обновление и конфликтующие библиотеки.
Первое исключено, т.к. это первая установка на этом копьютере.
С библиотеками раньше не было ровно ни одного конфликта
hosts доступен на запись, свободного места на диске - 3Г, свободной ОЗУ - более 1.5Г.
Логов нет никаких. Нигде. Не успевают, видимо :)

Пытался найти предыдущую версию (5.0), не нашёл.
Может, дадите ссылочку?

Спасибо.
Дмитрий.
Вложения
open5.PNG
open3.PNG
open2.PNG
open1.PNG

Аватара пользователя
Максим
Сообщения: 4872
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 25 июн 2015, 12:00

kartavenko, пункт Первый Запуск выполнялся?


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей