Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 774 раза!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
VladimirB
Сообщения: 1
C нами: 2 года 4 мес

Непрочитанное сообщение VladimirB » 24 июл 2014, 15:44

Здраствуйте) Уважаемые админы. Прочитал тему форума. По настройке Open server для локального компьютера. Чтоб сайт был доступен внутри локальной сети. Самого интересует этот вопрос. Я так понял если я написал этот вопрос то меня забанят, но действительно никто толком на него ответил. Может админ сайта поможет и ответит один раз толково чтоб не психовать по 100 раз.
P. S. 1)Очень надо данная функция 2) В руководство пользователя написано не понятно!!!!!
Я настраивал так сервер.
1) на вкладке Сервер - IP-адрес сервера: 192.168.1.5 - domains
2) на вкладке Алиасы : testst => domfold
3) вкладка домены: domfold - \domfold

Затем в адресной строке компьютера с ip-адресом 192.168.1.5 ввожу: http://domfold - все работает

4) Так же как в руководстве было написано добавил: в DNS данный ip 192.168.1.5

Потом перехожу на другой компьютер у него ip-адрес 192.168.1.42
так же сделал добавил: в DNS ip 192.168.1.5

Вот а теперь вопрос как мне запустить сайт с компьютера с Ip 192.168.1.42 на компьютере с ip 192.168.1.5???????????
На компьютере с ip 192.168.1.42 в адресной строке ввожу например:
http://192.168.1.5/openserver/ - открывается опенсервер
А КАК Сайт запустить перепробывал кучу вариантов:
http://192.168.1.5/domfold/
http://192.168.1.5/domfold/index.html
http://domfold/
Ничего не работает!!!! Прошу помочь!!! В руководстве конкретно не написано ничего!!!(

srudick
Сообщения: 10
C нами: 2 года 4 мес

Непрочитанное сообщение srudick » 26 июл 2014, 06:30

Кстати к предыдущему моему посту: работаю пока в отладочном режиме и при каждой загрузке-перезагрузке сервера у меня появляются по три командных окна, которые не закрываются сами ни по остановке сервера, ни по выходу из него вообще. Т.к. при работе я их просто сворачиваю, то они накапливаются и недавно пришлось закрывать их более 30 штук. Нельзя ли в отладочном режиме закрывать их автоматом после выхода из сервера?

Kostyauu
Сообщения: 6
C нами: 2 года 4 мес

Непрочитанное сообщение Kostyauu » 28 июл 2014, 08:08

при очередном запуске говорит: не найден звуковой файл программа будет закрыта. Я вроде ничего не удалял. Кто то сталкивался? Где найти звуковой файл и где он должен находиться?

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 29 июл 2014, 23:48

srudick, нужен доступ через тимвьювер в личку.

Kostyauu, Ого. А может ещё говорит что не найдена порнуха с Памелой Андерсон? Open Server не выдаёт таких сообщений.

VladimirB, убедитесь что на удалённом компьютере вы вписали адрес DNS Open Server первым в списке, а так же то, что вы вписали его именно в том подключении, которое используется для интернета или локальной сети. Если не можете самостоятельно настроить DNS то не мучайте себя, а просто создайте алиас ip=>домен как это указано в руководстве и заходите на сайт по IP адресу.

Goldsmit
Сообщения: 5
C нами: 2 года 4 мес

Непрочитанное сообщение Goldsmit » 30 июл 2014, 01:34

Эх...попытка №2 :D
1)
скрин.jpg

2) Содержимое файла server\system\profiles\ваш_профиль.ini
[main]
start=10
allow=1
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=172.22.46.27
http_log=1
mysql_log=1
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.2"
httpdriver="Apache-2.2"
mysql_driver="MySQL-5.5"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=1
showfvr=0
showprogs=1
hdomains=0
balloon=1
favorite=0
showswitch=1
debugmode=1
stext=0
sbrowser=0
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser=""
textred=""
filebrowser=""
sfilebrowser=0
fzone=none
speed=0
maxrequests=0
upurl=http://open-server.ru/update/
durl=http://open-server.ru/download/
folders="public_html www\htdocs www http htdocs docs web httpdocs public html site"

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""

3) Windows 7 Домашняя Расширенная SP1 x64, работаю под администратором,антивирус: ESET NOD32 Antivirus ver. 4.2.67.10; Фаерволы отсутствуют. Брандмауэр отключен как служба. Apache-2,2; PHP-5.2; MySQL-5.5;
4)
Основной:
2014-07-30 06:12:48  --------------------------------------------
2014-07-30 06:12:48  Начало процедуры запуска сервера
2014-07-30 06:12:48  Обновление Hosts файла
2014-07-30 06:12:48  Обновление конфигурации MySQL-5.5
2014-07-30 06:12:48  Обновление конфигурации Sendmail
2014-07-30 06:12:48  Обновление конфигурации PHP-5.2
2014-07-30 06:12:48  Обновление конфигурации PHPMyAdmin
2014-07-30 06:12:48  Обновление конфигурации Apache-2.2
2014-07-30 06:12:48  Запуск MySQL-5.5
2014-07-30 06:12:48  Запуск Apache-2.2
2014-07-30 06:12:48  Проверка состояния сервера
2014-07-30 06:13:13  Не удалось запустить Apache-2.2
2014-07-30 06:13:13  Сбой запуска!
2014-07-30 06:13:13  --------------------------------------------
2014-07-30 06:13:13  Начало процедуры остановки сервера
2014-07-30 06:13:13  Остановка системных модулей
2014-07-30 06:13:15  Отключение виртуального диска
2014-07-30 06:13:15  Веб-сервер успешно остановлен!


Apache запросы:
site.ru: 172.22.46.27 [30/Jul/2014:06:13:09 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:09 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:09 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:09 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:09 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:09 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:09 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:10 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:11 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:12 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
site.ru: 172.22.46.27 [30/Jul/2014:06:13:13 +0800] "GET /openserver/check.html HTTP/1.0" 404 1079 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"


Apache отладка:
[Wed Jul 30 06:12:49 2014] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Wed Jul 30 06:12:49 2014] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Wed Jul 30 06:12:49 2014] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Wed Jul 30 06:12:50 2014] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Wed Jul 30 06:12:50 2014] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Wed Jul 30 06:12:50 2014] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Wed Jul 30 06:12:58 2014] [notice] mod_bw : Memory Allocated 0 bytes (each conf takes 40 bytes)
[Wed Jul 30 06:12:58 2014] [notice] mod_bw : Version 0.92 - Initialized [0 Confs]
[Wed Jul 30 06:12:58 2014] [notice] mod_bw : Supported resolution for Timers [ Min: 1 Max: 1000000 ]
[Wed Jul 30 06:12:58 2014] [notice] mod_bw : Enabling High resolution timers [ 1 ms ]
[Wed Jul 30 06:12:58 2014] [notice] Apache/2.2.27 (Win32) mod_ssl/2.2.27 OpenSSL/0.9.8za mod_bw/0.92 configured -- resuming normal operations
[Wed Jul 30 06:12:58 2014] [notice] Server built: Mar 21 2014 10:41:53
[Wed Jul 30 06:12:58 2014] [notice] Parent: Created child process 2564
[Wed Jul 30 06:12:58 2014] [notice] Disabled use of AcceptEx() WinSock2 API
[Wed Jul 30 06:12:59 2014] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Wed Jul 30 06:12:59 2014] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Wed Jul 30 06:12:59 2014] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Wed Jul 30 06:13:00 2014] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Wed Jul 30 06:13:00 2014] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Wed Jul 30 06:13:00 2014] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Wed Jul 30 06:13:09 2014] [notice] mod_bw : Memory Allocated 0 bytes (each conf takes 40 bytes)
[Wed Jul 30 06:13:09 2014] [notice] mod_bw : Version 0.92 - Initialized [0 Confs]
[Wed Jul 30 06:13:09 2014] [notice] mod_bw : Supported resolution for Timers [ Min: 1 Max: 1000000 ]
[Wed Jul 30 06:13:09 2014] [notice] mod_bw : Enabling High resolution timers [ 1 ms ]
[Wed Jul 30 06:13:09 2014] [notice] Child 2564: Child process is running
[Wed Jul 30 06:13:09 2014] [notice] Child 2564: Acquired the start mutex.
[Wed Jul 30 06:13:09 2014] [notice] Child 2564: Starting 32 worker threads.
[Wed Jul 30 06:13:09 2014] [notice] Child 2564: Listening on port 443.
[Wed Jul 30 06:13:09 2014] [notice] Child 2564: Listening on port 80.
[Wed Jul 30 06:13:09 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:09 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:09 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:09 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:09 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:09 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:09 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:10 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:11 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:12 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver
[Wed Jul 30 06:13:13 2014] [error] [client 172.22.46.27] File does not exist: C:/OpenServer/domains/172.22.46.27/openserver


MySQL запросы:
C:\OpenServer\modules\database\MySQL-5.5\bin\mysqld.exe, Version: 5.5.38-log (MySQL Community Server (GPL)). started with:
TCP Port: 3306, Named Pipe: (null)
Time                 Id Command    Argument


MySQL отладка:
140730  6:12:48 [Note] Plugin 'FEDERATED' is disabled.
140730  6:12:48 InnoDB: The InnoDB memory heap is disabled
140730  6:12:48 InnoDB: Mutexes and rw_locks use Windows interlocked functions
140730  6:12:48 InnoDB: Compressed tables use zlib 1.2.3
140730  6:12:48 InnoDB: Initializing buffer pool, size = 20.0M
140730  6:12:48 InnoDB: Completed initialization of buffer pool
140730  6:12:48 InnoDB: highest supported file format is Barracuda.
140730  6:12:49  InnoDB: Waiting for the background threads to start
140730  6:12:50 InnoDB: 5.5.38 started; log sequence number 1595675
140730  6:12:50 [Note] Server hostname (bind-address): '172.22.46.27'; port: 3306
140730  6:12:50 [Note]   - '172.22.46.27' resolves to '172.22.46.27';
140730  6:12:50 [Note] Server socket created on IP: '172.22.46.27'.
140730  6:12:50 [Note] Event Scheduler: Loaded 0 events
140730  6:12:50 [Note] C:\OpenServer\modules\database\MySQL-5.5\bin\mysqld.exe: ready for connections.
Version: '5.5.38-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
140730  6:13:13 [Note] C:\OpenServer\modules\database\MySQL-5.5\bin\mysqld.exe: Normal shutdown

140730  6:13:13 [Note] Event Scheduler: Purging the queue. 0 events
140730  6:13:13  InnoDB: Starting shutdown...
140730  6:13:14  InnoDB: Shutdown completed; log sequence number 1595675
140730  6:13:14 [Note] C:\OpenServer\modules\database\MySQL-5.5\bin\mysqld.exe: Shutdown complete


5) Вот описание проблемы, в другой теме. Вот ссылка.

Руководство пользователя прочитал от корки до корки, все пункты из раздела Решение проблем в руководстве выполнил!

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 30 июл 2014, 01:39

Goldsmit, вы удалили служебную часть конфигурации HTTP модуля т.е. испортили служебный конфиг, либо заменили этот конфиг на несовместимый (например от более строй версии Open Server).

Goldsmit
Сообщения: 5
C нами: 2 года 4 мес

Непрочитанное сообщение Goldsmit » 30 июл 2014, 01:43

Это странно, я специально перед тем как отправлять логи, переустановил Open Server. Старой версии не должно было остаться. Скорее всего как-то удалил служебную часть... :?

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 30 июл 2014, 01:45

Goldsmit, не понятно о какой переустановке вы говорите. Open Server не нуждается в установке, его нужно лишь распаковать. И если вы его лишь распаковали и сразу запустили, то такой ошибки быть не может.

Goldsmit
Сообщения: 5
C нами: 2 года 4 мес

Непрочитанное сообщение Goldsmit » 30 июл 2014, 01:50

Извиняюсь, распаковал. Вот и я думаю что не может. Но она есть...значит буду разбираться, спасибо что указали на проблему...

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 30 июл 2014, 01:54

Goldsmit писал(а):Извиняюсь, распаковал. Вот и я думаю что не может. Но она есть...значит буду разбираться, спасибо что указали на проблему...


Ну такого быть не может :) Если хотите давайте я сам посмотрю, нужен доступ к тимвьюверу. Если конечно хотите.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей