Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 278 632 раза!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Аватара пользователя
Максим
Сообщения: 5132
C нами: 6 лет 8 мес
Контакты:

Непрочитанное сообщение Максим » 02 мар 2017, 10:04

Cynic писал(а):К сожалению, и в текущей версии (опробованы: open_server_5_2_6_basic и open_server_5_2_6_ultimate, загруженные с ospanel.io несколько дней назад) присутствует этот же баг (приводящий к моментальному вылету с сообщением об ошибке).


Я вам до этого про какую версию писал по вашему? Про версию 10-ти летней давности чтоль? Сообщил же русским языком, что ждите выхода новой версии. В текущей версии к сожалению нет встроенного механизма отлова ошибок. В будущей версии он будет.

Cynic
Сообщения: 3
C нами: 5 мес 16 дней

Непрочитанное сообщение Cynic » 02 мар 2017, 17:44

Максим писал(а):Я вам до этого про какую версию писал по вашему?

Про "будущую". ;)
В явном виде номер указан не был, а исходя из:
Денис325 писал(а):Может ли быть проблема в версии?
версия 5.2.5

... я предположил, что о ней и речь [а 5.2.6 уже следующая и сведений о проявлении данного глюка в ней я не видел].
(Хотя, каюсь, мог глянуть в хронологию и сформулировать вопрос по-иному: просто уточнить - какой версии/-ий это касается. Тем более что рапорт оси: "Версия приложения: 5.2.2.0" также ясности не добавляет. )

В любом случае - спасибо. Ответ внёс ясность, что проблема касается как минимум и 5.2.5 и 5.2.6, причем может проявляться как x86, так и x64...
Также я сделал вывод, что на случай проявления такой проблемы "на выезде" - нужно иметь при себе флешку, с которой можно загрузиться и отработать/продемонстрировать.

PS Если какая-либо диагностика, [для которой нужна "живая" тестовая система, в которой проявляется данный баг] может быть полезна - готов оказать посильное содействие.

Аватара пользователя
Максим
Сообщения: 5132
C нами: 6 лет 8 мес
Контакты:

Непрочитанное сообщение Максим » 02 мар 2017, 19:45

Cynic, можете скинуть в личку доступ к тимвьюверу, когда я буду в сети. Думаю за полчаса найдём в какой иконке у вас проблема.

Cynic
Сообщения: 3
C нами: 5 мес 16 дней

Непрочитанное сообщение Cynic » 04 мар 2017, 06:43

Максим писал(а):за полчаса найдём в какой иконке у вас проблема.

Если это поможет Вам в поиске/устранении бага - имеет смысл.
А если просто найти какой иконки не хватает у меня - не стоит тратить Ваше время.
(Описанное выше - проявилось на "тестовой" системе, в которой я работать не буду. А в "основной" - всё работает корректно.)

PS И ещё раз спасибо за доброжелательный подход к пользователям.

Аватара пользователя
Максим
Сообщения: 5132
C нами: 6 лет 8 мес
Контакты:

Непрочитанное сообщение Максим » 04 мар 2017, 12:08

Cynic, для чего мне искать баг если я вам уже написал что в будущей версии OSP с этим будет полный порядок, там это УЖЕ исправлено и даже будет режим отлова ошибок. Я говорил лишь о том, что можно найти проблему У ВАС сейчас если вам это нужно. Но судя по вашим словам, вам это не нужно т.к. в тестовой системе вы работать не будете, так что вопрос закрываем.

webgrig
Сообщения: 2
C нами: 1 год

Непрочитанное сообщение webgrig » 15 мар 2017, 17:21

Сервер перестает запускаться после попытки установить галочку "Запускать сервер в отладочном режиме".

В логах читаю следующее:
2017-03-15 16:13:21 --------------------------------------------
2017-03-15 16:13:21 Начало процедуры запуска сервера
2017-03-15 16:13:21 Обновление Hosts файла
2017-03-15 16:13:21 Обновление конфигурации MySQL-5.5
2017-03-15 16:13:21 Обновление конфигурации Sendmail
2017-03-15 16:13:21 Обновление конфигурации PHP-5.3
2017-03-15 16:13:21 Обновление конфигурации PHPMyAdmin
2017-03-15 16:13:21 Обновление конфигурации Apache-2.2
2017-03-15 16:13:21 Запуск MySQL-5.5
2017-03-15 16:13:21 Запуск Apache-2.2
2017-03-15 16:13:21 Проверка состояния сервера
2017-03-15 16:13:57 Не удалось запустить Apache-2.2
2017-03-15 16:13:57 Не удалось запустить MySQL-5.5
2017-03-15 16:13:57 Сбой запуска!
2017-03-15 16:13:57 --------------------------------------------
2017-03-15 16:13:57 Начало процедуры остановки сервера
2017-03-15 16:13:57 Остановка системных модулей
2017-03-15 16:13:57 Отключение виртуального диска
2017-03-15 16:13:57 Сервер успешно остановлен за 0,313 секунд!


А вообще необходимость запустить сервер в отладочном режиме возникла после того, как я попытался поменять версию PHP и поднял ее до PHP-7.0-x64 и получил сбой запуска сервера.
Помогите пож. разобраться, что к чему, и как запустить Open Server с PHP7 на машине с Windows 8.1

Аватара пользователя
Максим
Сообщения: 5132
C нами: 6 лет 8 мес
Контакты:

Непрочитанное сообщение Максим » 15 мар 2017, 17:24

webgrig, пожалуйста, изучите правила оформления сообщений на первой странице темы.

webgrig
Сообщения: 2
C нами: 1 год

Непрочитанное сообщение webgrig » 15 мар 2017, 17:51

Итак:
1. скрины четырех отладочный окон дать не могу, так как при запуске серверв в отладочном режиме происходит сбой и не открываются ни какие отладочные окна;
2. содержание файла e:\OpenServer\userdata\profiles\Default.ini
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=0
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.3"
httpdriver="Apache-2.2"
mysql_driver="MySQL-5.5"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=0
favorite=0
showswitch=1
debugmode=1
stext=1
sbrowser=1
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser="%realprogdir%\progs\_Internet\GoogleChromePortable\GoogleChromePortable.exe"
textred="%realprogdir%\progs\_Office\Notepad++\notepad++.exe"
filebrowser=""
sfilebrowser=0
maxrequests=0
folders=""

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""


версия системы windows 8.1 / 64 битная
Open Server запускаю под администратором
антивирусов нет
фаервол отключен

Содержимое вкладок логов:
заполнена только одна вкладка - "Основной", остальные вкладки пусты
2017-03-15 16:47:22  --------------------------------------------
2017-03-15 16:47:22  Начало процедуры запуска сервера
2017-03-15 16:47:23  Обновление Hosts файла
2017-03-15 16:47:23  Обновление конфигурации MySQL-5.5
2017-03-15 16:47:23  Обновление конфигурации Sendmail
2017-03-15 16:47:23  Обновление конфигурации PHP-5.3
2017-03-15 16:47:23  Обновление конфигурации PHPMyAdmin
2017-03-15 16:47:23  Обновление конфигурации Apache-2.2
2017-03-15 16:47:23  Запуск MySQL-5.5
2017-03-15 16:47:23  Запуск Apache-2.2
2017-03-15 16:47:23  Проверка состояния сервера
2017-03-15 16:47:58  Не удалось запустить Apache-2.2
2017-03-15 16:47:58  Не удалось запустить MySQL-5.5
2017-03-15 16:47:58  Сбой запуска!
2017-03-15 16:47:58  --------------------------------------------
2017-03-15 16:47:58  Начало процедуры остановки сервера
2017-03-15 16:47:58  Остановка системных модулей
2017-03-15 16:47:58  Отключение виртуального диска
2017-03-15 16:47:58  Сервер успешно остановлен за 0,297 секунд!

UseLess
Сообщения: 3
C нами: 4 мес 19 дней

Непрочитанное сообщение UseLess » 29 мар 2017, 09:40

Первый раз на форуме. Создал тему viewtopic.php?f=3&t=3140 . Не знаю относится ли это к НЕ ЗАПУСКУ. Извините.

Sans84
Сообщения: 2
C нами: 4 мес 14 дней

Непрочитанное сообщение Sans84 » 03 апр 2017, 21:55

Не запускается сервер на Apache-PHP7 (без разницы какой модификации). Вылетает системная ошибка httpd.exe из-за отсутствия api-ms-win-*.dll. Форточка Win7 x64. VC установлен. В чем проблема?


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя