Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Аватара пользователя
Максим
Сообщения: 5406
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Сервер не запускается? Пиши СЮДА!

Максим » 10 июн 2018, 22:16

К сожалению мне пока нечего на это ответить. Оригинальный конфиг-файл mysql находится в windows-1251 кодировке и в такой же сохраняется. Почему на Windows 10 после некого обновления повально началось сохранение файла в UTF-8 кодировке да еще и с BOM - мне не понятно.

По всей видимости это некий новый прикол Windows 10, надо будет с этим разбираться. В любом случае если проблема в сохранении файла во время создания временного конфига, то это будет исправлено только в следующем поколении Open Server, разработку которого я сейчас веду.

Напомню, что текущая версия в Windows 10 не тестировалась и работоспособность там не гарантируется.
wormen86
Сообщения: 213
Зарегистрирован:
14 окт 2013, 05:19

Re: Сервер не запускается? Пиши СЮДА!

wormen86 » 11 июн 2018, 03:32

К сожалению мне пока нечего на это ответить. Оригинальный конфиг-файл mysql находится в windows-1251 кодировке и в такой же сохраняется. Почему на Windows 10 после некого обновления повально началось сохранение файла в UTF-8 кодировке да еще и с BOM - мне не понятно.
Microsoft, примерно 1-2 месяца назад сделали поддержку utf8, и сосем недавно на нее перешли, поэтому сейчас все файлы, по умолчанию сохраняются в utf8
так же связано с развитием WSL
Напомню, что текущая версия в Windows 10 не тестировалась и работоспособность там не гарантируется.
на самой последней версии Window 10, все стабильно работает, и точно так же без всяких проблем, нормально устанавливается
Аватара пользователя
ulukay
Сообщения: 96
Зарегистрирован:
29 мар 2016, 14:02

Re: Сервер не запускается? Пиши СЮДА!

ulukay » 11 июн 2018, 19:50

Wadimich писал(а):
10 июн 2018, 01:23
Никак не удается запустить OpenServer на Windows 10 x64.

Выставил себе последние версии x64 apache, mysql, php, mongodb.

При запуске сервера временный конфиг сохраняется в UTF-8 With BOM, из-за этого не запускается MySQL сервер. Сам конфиг MySQL вообще не открывался, установка чистая.

Работает, если вручную пересохранить конфиг без BOM, и вручную запустить mysql, но это как-то костыльно.

Антивирус стандартный, папка в игноре.

Как можно побороть проблему?
Специально рапаковал open_server_5_2_8_ultimate с нуля (мой просто уже издураченный(обновления, улучшения, "ухудшения", ковыряние под себя и т.д). Выбрал указанные вами модули, запустил сервер (всё запустилось)Windows 10 Pro v1803 сборка 17134.81 т.е. самая последняя со всеми обновами. Заглянул во временные конфиги выбранных модулей результат один - все созданны в формане windows 1251.
Не понятно как вам удаётся их исправить если они перезаписываются! Если вы правите конфиг модуля из папки \OSPanel\userdata\config\ то надобно видимо выбрать в редакторе коим вы пользуетесь соответствующею кодировку в настройках. И всё. Пример на картинке для Notepad++
Никита Панюхин
Сообщения: 3
Зарегистрирован:
16 июн 2018, 12:29

Re: Сервер не запускается? Пиши СЮДА!

Никита Панюхин » 16 июн 2018, 12:53

Здравствуйте. Не запускается open server с настройками:
http://pths.n-panuhin.ru/admin-tools/images/1.png
http://pths.n-panuhin.ru/admin-tools/images/2.png
http://pths.n-panuhin.ru/admin-tools/images/3.png
Вот логи:
http://pths.n-panuhin.ru/admin-tools/images/4.png
http://pths.n-panuhin.ru/admin-tools/images/5.png
Остальные - пустые.
Операционная система - Windows 10
Очень надеюсь на вашу помощь.
P.S. Пробывал отключать всю защиту компьютера, но безуспешно.
Аватара пользователя
Максим
Сообщения: 5406
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Сервер не запускается? Пиши СЮДА!

Максим » 16 июн 2018, 13:51

ulukay, спасибо что проверили, значит вышенаписавшие на форуме врут, что не редактировали конфиги после распаковки сервера. А я уж было подумал проблема в программе или в Windows, оказалось что всё же люди не умеют работать с текстовым редактором :-)
Аватара пользователя
ulukay
Сообщения: 96
Зарегистрирован:
29 мар 2016, 14:02

Re: Сервер не запускается? Пиши СЮДА!

ulukay » 16 июн 2018, 16:46

Всё верно Максим.
И уж в UTF с BOM, винда точно не будет писать! Видимо пока PHP не научат распознавать этот маркер.
Никита Панюхин
Сообщения: 3
Зарегистрирован:
16 июн 2018, 12:29

Re: Сервер не запускается? Пиши СЮДА!

Никита Панюхин » 16 июн 2018, 23:32

Здравствуйте. Пишу ещё раз, т.к. случайно удалил фотографии с прошлого поста. Мне очень нужна ваша помощь. Если нужно что-то ещё дослать. то скажите. Пожалуйста помогите решить проблему. Вот всё заново, с большим кол-вом фотографий:

Ситуация:
При обычном запуске (Apache 2.4 + PHP 5.6) всё отлично, но если включить Apache 2.2 + PHP 7.0 то он сначала долго загружается (горит жёлтым), а потом выдаёт ошибки (представлены ниже)
Настройки:
http://pths.n-panuhin.ru/admin-tools/images/1.png
http://pths.n-panuhin.ru/admin-tools/images/2.png
http://pths.n-panuhin.ru/admin-tools/images/3.png
http://pths.n-panuhin.ru/admin-tools/images/4.png
http://pths.n-panuhin.ru/admin-tools/images/5.png
http://pths.n-panuhin.ru/admin-tools/images/6.png
http://pths.n-panuhin.ru/admin-tools/images/7.png
Вот логи, остальные - пустые:
http://pths.n-panuhin.ru/admin-tools/images/8.png
http://pths.n-panuhin.ru/admin-tools/images/9.png
http://pths.n-panuhin.ru/admin-tools/images/10.png
Операционная система - Windows 10
Очень надеюсь на вашу помощь.
P.S. Пробовал отключать всю защиту компьютера, но безуспешно.
Аватара пользователя
Максим
Сообщения: 5406
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Сервер не запускается? Пиши СЮДА!

Максим » 17 июн 2018, 01:00

Никита Панюхин, для работы с PHP7 там есть отдельный пункт APACHE-PHP7. То что выбираете вы - работать не будет.
Никита Панюхин
Сообщения: 3
Зарегистрирован:
16 июн 2018, 12:29

Re: Сервер не запускается? Пиши СЮДА!

Никита Панюхин » 17 июн 2018, 10:07

Понял. Спасибо огромное
Besedin
Сообщения: 6
Зарегистрирован:
25 мар 2014, 13:18

Re: Сервер не запускается? Пиши СЮДА!

Besedin » 17 июн 2018, 18:53

Максим писал(а):
16 июн 2018, 13:51
ulukay, спасибо что проверили, значит вышенаписавшие на форуме врут, что не редактировали конфиги после распаковки сервера. А я уж было подумал проблема в программе или в Windows, оказалось что всё же люди не умеют работать с текстовым редактором :-)
Здравствуйте. Проводил инсталляцию с нуля. Пробовал сначала в папку юзера, а потом и просто в корень диска и ситуация точно такая же - MySQL не стартует из-за неверной кодировки сгенерированных конфиг-файлов. Оригинал в CP-1251, а на выходе UTF-8 BOM. Проблема возможно в чем нибудь другом. Была мысль что конвертация идет через то что запись шла в юзер директорию, которая автоматически монтируется в wsl, но нет. Не помогло.

Windows 10 Home 1803 (Build 17134.112)
Ответить