Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 986 раз!

Форум

Добро пожаловать, Гость!

Модули PHP7

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
GeekHacker
Сообщения: 94
C нами: 1 год 3 мес

Непрочитанное сообщение GeekHacker » 17 дек 2015, 23:46

Да и Максим в первом же сообщении об этом написал.

Аватара пользователя
-Vladislav-
Сообщения: 3
C нами: 11 мес 11 дней

Непрочитанное сообщение -Vladislav- » 30 дек 2015, 01:06

Отлично, ощутимый прирост, спасибо!

koftik
Сообщения: 4
C нами: 3 года 2 мес

Непрочитанное сообщение koftik » 07 янв 2016, 14:35

Максим писал(а):Apache нужен для совместимости с новым PHP (поэтому нельзя использовать уже имеющийся Apache 2.4). Поправлю это в следующей версии OS. То же самое и с названием PHP5.6-5.7 из-за проверки совместимости.

Для тех кого смущает не конкретные имена у себя сделал так:
Папки переименовал в Apache-PHP-7.0 и PHP-7.0
Файлы настроек в Apache-PHP-7.0_server.conf, Apache-PHP-7.0_vhost.conf и PHP-7.0_php.ini

Своего рода отключение встроенной блокировки + красивые понятные пути.

kyvour
Сообщения: 12
C нами: 1 год 11 мес

Непрочитанное сообщение kyvour » 09 янв 2016, 01:17

Это своего рода дополнение? Старый апач и php5 будут продолжать работать?

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 09 янв 2016, 05:35

kyvour, да, конечно продолжат.

Stickeyd
Сообщения: 1
C нами: 10 мес 27 дней

Непрочитанное сообщение Stickeyd » 13 янв 2016, 17:55

Данная сборка нестабильна. После ее установки у меня и ещё одного человека перестал работать генератор моделей в генераторе кода gii фреймворка Yii2. Apache просто умирал. Ещё есть баги, нужно фиксить. Хоть и все остальное работало стабильно, но баги явно есть. Нужно ещё править

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 13 янв 2016, 19:16

Stickeyd писал(а):Данная сборка нестабильна. После ее установки у меня и ещё одного человека перестал работать генератор моделей в генераторе кода gii фреймворка Yii2. Apache просто умирал. Ещё есть баги, нужно фиксить. Хоть и все остальное работало стабильно, но баги явно есть. Нужно ещё править


А что править то собрались? Генератор кода gii фреймворка Yii2? Или исходники апача? Если апач, то напишите непосредственно его разработчикам, а то не по адресу обратились.

Аватара пользователя
Russlav
Сообщения: 50
C нами: 1 год 2 мес
Откуда: Краснодар

Непрочитанное сообщение Russlav » 14 янв 2016, 15:41

Здравствуйте, уже вышел php 7.0.1, а в Open Server его ещё нет, когда он будет (будет ли вообще)?

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 14 янв 2016, 15:43

Russlav писал(а):Здравствуйте, уже вышел php 7.0.1, а в Open Server его ещё нет, когда он будет (будет ли вообще)?


Вообще-то PHP 7.0.2 уже есть. Будет, в этой теме, чуть позже.

Аватара пользователя
Russlav
Сообщения: 50
C нами: 1 год 2 мес
Откуда: Краснодар

Непрочитанное сообщение Russlav » 14 янв 2016, 16:08

Всё понял (прочитал всю тему).


Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей