Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 018 707 раз!

Форум

Добро пожаловать, Гость!

Php страницы открывает, а html нет

Обсуждение проблем в работе программного комплекса
naKotik
Сообщения: 2
C нами: 1 год 9 мес

Непрочитанное сообщение naKotik » 07 фев 2015, 19:09

Здрастуйте, установил openserver на ноутбук. добавил новый алиас вида "мой-ip в локалке" => test.com (для доступа по локальной сети к файлам с планшета - через роутер) соответственно создал папку OpenServer\domains\test.com в которой два файла index.html и index.php.
в настройки/сервер изменил ip на тот же что в алиасе. при наборе с ноутбука в браузере ip или test.com срабатывает файл index.php если поместить туда файл index.html выдает: Это файл /home/test1.ru/www/index.html
пробовал удалить файл с расширением php ничего не меняется. я ж так понимаю что открывать html он должен? как можно исправить проблему.
на планшете в файл hosts добавил строчку мой-ip test.com --- доступ не работает ни к php ни к html

[upd=1423329807][/upd]
сорян за тупость. проблема с кодировкой была. потому html не запускался.

ну а на счет локалки вроде тем много поищу что то в других темах :)

[upd=1423354108][/upd]
Проблема того что не виделось с планшета была в антивирусе фаервол блокировал, что б его :D Ave автору сего чуда.

[upd=1423417705][/upd]
Ребят остался вопрос. Для внешнего доступа файервол блокирует что бы не отключать его для чего нужно открыть порт 80 файерволе для openserver.exe или для чего то еще?

naKotik
Сообщения: 2
C нами: 1 год 9 мес

Непрочитанное сообщение naKotik » 10 фев 2015, 01:30

отвечу сам - для apache


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и 1 гость