Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 161 раз!

Форум

Добро пожаловать, Гость!

Не открывается окно настроек

Обсуждение проблем в работе программного комплекса
StIX
Сообщения: 5
C нами: 3 года 11 мес

Непрочитанное сообщение StIX » 21 дек 2012, 18:15

При открытии пункта "настройки" в меню программы вылетает сообщение:
scr.png

само окно настроек после этого не открывается.
В пути к папке с программой нет не русских символов, не каких-либо спецсимволов. Запуск от администратора или нет, установка в корень диска ничего не дают. На более ранних версиях такого у меня не было.

Версия программы: 4.7.4
Файл конфигурации:
[main]
start=5
allow=1
emformat=txt
maxmemcache=64
cgiprocess=5
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
mysqlrootpass=
postgresqlpass=
dbdriver=MySQL-5.1.66
mysqlcharset=utf8_general_ci
phpdriver=PHP-5.2.17
httpdriver=Apache-2.2.23
httpcharset=notset
logreadsize=256
showversion=1
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=1
favorite=0
showswitch=1
debugmode=0
stext=0
sbrowser=0
mysql=1
email=0
vdisk=W
webdir=domains
browser=
textred=
filebrowser=
sfilebrowser=0
upurl=http://open-server.ru/update/
durl=http://open-server.ru/download.html

[ports]
mysqlport=3306
postgresqlport=5432
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
phpport=9000
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=
smtp_port=
auth_username=
auth_password=
smtp_ssl=0
pop3_server=
pop3_username=
pop3_password=
force_sender=

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 21 дек 2012, 19:40

Запакуйте пожалуйста всю папку с сервером(кроме папки domains) в архив и отправьте на info собака open-server.ru
Без изучения наживую я вам ничем помочь не смогу.

StIX
Сообщения: 5
C нами: 3 года 11 мес

Непрочитанное сообщение StIX » 21 дек 2012, 21:00

Я думаю, что в этом нет не какого смысла, т.к. я просто распаковал программу не внося не каких изменений. Сейчас даже перекачал архив с программой и попробовал ещё раз, толку нет. Возможно дело не в программе, а в моей системе... (Windows 7 Ultimate 64-bit SP1)

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 21 дек 2012, 21:23

Спасибо за пояснение, тогда действительно проблема не в сделанных вами изменениях и настройках. Хочу попросить вас предоставить доступ через тимвьювер для поиска и устранения ошибки в программе, этим вы очень поможете проекту, ведь такая ошибка может возникнуть не только у вас. По другому к сожалению никак, нужен доступ к вашему компьютеру, справлюсь минут за 20, максимум минут 40, смотря сколько буду тестировать open server.

Вообще тут скорее всего проблема в имени диска или в локальных переменных PATH, а может и что-то другое. Пока не найду не узнаем :-)

StIX
Сообщения: 5
C нами: 3 года 11 мес

Непрочитанное сообщение StIX » 21 дек 2012, 21:50

Проблема действительно в моей системе. Сейчас создал новую учётную запись и загрузился с неё, и всё заработало. А от моей не хочет, по не понятной причине. Возможно действительно переменные окружения сбиты. Данные тимвьювера в лс.

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 21 дек 2012, 22:47

Как только выложу исправленный скрипт - отпишусь тут.

StIX
Сообщения: 5
C нами: 3 года 11 мес

Непрочитанное сообщение StIX » 21 дек 2012, 22:50

Хорошо. Хотя в принципе торопиться то не куда, когда реально надумаете обновлять программу тогда и включите это исправление. Я пока просто авто запуск включу.

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 21 дек 2012, 23:41

Я конечно в новостях не сообщаю каждый раз, но после каждой исправленной проблемы обновляю архивы на сервере чтобы вновь скачавшие пользователи не получали ошибку, если она уже устранена.

Архивы обновил. Еще раз спасибо.

P.S. Что за антивирус у вас такой, который автозагрузку отключает? :-) Касперский?

StIX
Сообщения: 5
C нами: 3 года 11 мес

Непрочитанное сообщение StIX » 21 дек 2012, 23:59

Хорошо, обновлюсь. Хотя я разобрался в чем дело, по началу вообще не так понял о чем речь. Создал папки:
..\Users\All Users\Microsoft\Windows\Start Menu\Programs\Startup
%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

и заработало :)

Антивирус касперский, но тут не касперский виноват, а я. Видимо случайно удалил эту папку когда чистил меню пуск от хлама.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей