Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 016 533 раза!

Форум

Добро пожаловать, Гость!

Предложения и пожелания

Обсуждение общих вопросов связанных с программой
Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 20 дек 2012, 20:32

tizerenko писал(а):Вот ссылка http://sourceforge.net/projects/nbportable/files/Version 7.2 Beta/PHP/


Спасибо, программа полезная. Но она весит в половину всего пакета программ + требует еще установленный Java, иначе работать не будет... тогда вообще получится не портативно :-( Так что врятли.

woka
Сообщения: 3
C нами: 4 года

Непрочитанное сообщение woka » 21 дек 2012, 02:18

tizerenko писал(а):
Сделайте возможность, что-то типа конструктора для скачивания(кухня). Например выбираешь нужные пакеты и скачиваешь сборку заточенную под себя. Просто скачивать по 4 версии php, apache, mysql и других программ, которые просто занимают место на диске, как-то неправильно.

Тогда придётся ещё делать отдельные конфиги для каждой сборки, ведь если там будет опция включить apache, mysql, php определённой версии,а их не будет, то это будет вдвойне не правельно, это же ведь не кодеки где они либо есть либо их нету, просто положи скопируй и усё, тут имеется панель для включения той или иной версии языка, разумеется если даже автор такую затею реализует появится оооочень много умников которые по своей тупости будут говорить что у них что-то не работает или чего то нету, когда скачали не полный дистрибутив.

Ничего переконфигурировать не прийдётся. Программа сама определяет какие модули в ней присутствуют(чтобы проверить удалите какой-нибудь модуль и перезапустите). Они и называются модули, что значит что всё будет работать и без их. Ну и в нынешних сборках нельзя выключить апач и рнр, следовательно и в тех сборках эта опция будет идти как стандартная.

tizerenko
Сообщения: 55
C нами: 4 года 2 мес

Непрочитанное сообщение tizerenko » 22 дек 2012, 21:11

Впринципе да, дистрибутив программы весит 107 мегабайт, с учётом того что большинство пользователей будет использовать стандартно принятые версии языка, бд и сервера можно подвести учёт сэкономленного места на диске:
В распакованном виде mysql (MariaDB-5.5.28a,MySQL-5.5.28,PostgreSQL-9.2.1) весят 223 мб , php (PHP-5.3.19,PHP-5.4.9) 131мб, сервера (Apache-2.2.23+Nginx-1.2.5, Apache-2.4.3, Nginx-1.2.5) 34 мб.
В итоге получается 388 мегабайт в распакованном виде будет сэкономлено, в погоне за минималистичностью конечно, но open-server не основан за погоней в минималистичности сборки, а напротив дать пользователю возможность использовать разные конфиги в одном дистрибутиве, всё конечно зависит от автора, но при желании можно смело удалить данные папки с языками и те языки что не удалены и включены будут работать.

skn78
Сообщения: 1
C нами: 3 года 11 мес

Непрочитанное сообщение skn78 » 24 дек 2012, 14:29

Можно ли добавить в сборку nodejs?

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 24 дек 2012, 16:13

skn78 писал(а):Можно ли добавить в сборку nodejs?


Насколько я понимаю nodejs невозможно использовать портативно, там нужно создавать файл в домене и запускать на конкретном порту для домена. А раз нельзя использовать портативно, то добавить его нельзя.

Вот тут один из пользователей подключил nodejs, можете воспользоваться его инструкцией: viewtopic.php?f=6&t=746

fastto
Сообщения: 1
C нами: 3 года 11 мес

Непрочитанное сообщение fastto » 25 дек 2012, 13:02

Добрый день!
В первую очереь хочу выразить невероятную благодарность )) Open Server - это круто!

Из пожеланий - хотелось бы видеть такой софт еще в коробке:

1) redis-server и ext php_redis к нему - это по сути и конфигурировать почти не нужно, просто в кинуть внутрь ))

2) KeePassX - бесплатный, не требующий установки менеджер паролей

Bro
Сообщения: 1
C нами: 3 года 11 мес

Непрочитанное сообщение Bro » 25 дек 2012, 14:40

Спасибо за отличную программу!

Пока читал руководство появилось небольшое замечание.
В справке, в разделе "Вопросы-ответы" написано что письма сохраняются в папке userdata/temp/email/, хотя почему-то у меня они сохраняются в другой папке userdata/tmp/email/. И сами письма не удаляются после остановки сервера. По правде сказать, мне как раз и надо, чтобы письма никогда не удалялись. В справке дана неточная информация или это у меня что-то не так? ;)

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 25 дек 2012, 15:04

fastto писал(а):Добрый день!
В первую очереь хочу выразить невероятную благодарность )) Open Server - это круто!

Из пожеланий - хотелось бы видеть такой софт еще в коробке:

1) redis-server и ext php_redis к нему - это по сути и конфигурировать почти не нужно, просто в кинуть внутрь ))

2) KeePassX - бесплатный, не требующий установки менеджер паролей



Спасибо, рассмотрю.

Добавлено спустя 30 секунд:
Bro писал(а):Спасибо за отличную программу!

Пока читал руководство появилось небольшое замечание.
В справке, в разделе "Вопросы-ответы" написано что письма сохраняются в папке userdata/temp/email/, хотя почему-то у меня они сохраняются в другой папке userdata/tmp/email/. И сами письма не удаляются после остановки сервера. По правде сказать, мне как раз и надо, чтобы письма никогда не удалялись. В справке дана неточная информация или это у меня что-то не так? ;)



Спасибо, это ошибка документации, исправлю.

web_developer
Сообщения: 3
C нами: 5 лет 2 мес

Непрочитанное сообщение web_developer » 25 дек 2012, 19:05

Всем привет.
Думаю что нужно изменить названия (папок) для модулей, особенно для PHP.
Обьясняю: я использую уіі фреймворк и соответственно я его вынес за пределы проэктов так как не охота постоянно копипастить целый фреймворк, да и в Windows environments подключил его.
О вот не задача, постоянно, когда обновляешь Сервер, если обновились модули, в часности и пых возникает проблемма.
Суть проблеммы: в Windows environments в path прописан путь к пых-интерпретатору, к примеру:
X:\Server\modules\php\PHP-5.3.19 и тут то вся проблемма, завтра я обновлю сервер, и там будет например PHP-5.3.100500 и мне обязательно нужно будет не забыть залесть в Windows environments и изменить path.
А вот если бы было так: X:\Server\modules\php\PHP-5.3 например, такой проблеммы бы небыло...так как мне пофиг что внутри, и так знаю что там пхп 5.3.х.
Если будет срачи типа: вот а как же тогда знать какой именно 5.3... Вопрос: зачем? достаточно что есть описание для версии программы и ее компонентов да и есть phpinfo.

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 25 дек 2012, 19:25

web_developer, если человеку для каких-то специальных проектов нужно использовать 3 разных версии php ветки 5.3:
5.3.1
5.3.4
5.3.10
Что тогда прикажете делать?

Если вы думали что установить самостоятельно нужный комплект php нельзя, то это вовсе не так, любой модуль можно установить самому и пользователи которые так делают есть.


Вернуться в «Обсуждение Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и 1 гость