Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 161 раз!

Форум

Добро пожаловать, Гость!

Падения Apache 2.* и PHP 5.3 при установке SilverStripe CMS 3.0

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
code32
Сообщения: 8
C нами: 4 года 4 мес

Непрочитанное сообщение code32 » 22 июл 2012, 10:57

На самом деле подобные падения были и при установке 1C Битрикс, но там повторная установка решала проблему. А в этом случае баг стабилен, и повторяется из раза в раз. Притом как на Apache 2.2 так и на Apache 2.4. PHP 5.2 я не проверял так как для установке CMS требуется PHP 5.3 минимум. А в PHP 5.4 не работает отладка через xdebug. Так что я в *опе. В логах ничего такого объясняющего происходящее нету. Прикладываю все что есть.

Сигнатура проблемы:
  Имя события проблемы:   APPCRASH
  Имя приложения:   httpd.exe
  Версия приложения:   2.4.2.0
  Отметка времени приложения:   4f7ed6c4
  Имя модуля с ошибкой:   php5ts.dll
  Версия модуля с ошибкой:   5.3.14.0
  Отметка времени модуля с ошибкой:   4fd8c608
  Код исключения:   c00000fd
  Смещение исключения:   0018b573
  Версия ОС:   6.1.7601.2.1.0.256.1
  Код языка:   1049
  Дополнительные сведения 1:   e339
  Дополнительные сведения 2:   e339f2594e7f681a95b166793376bebb
  Дополнительные сведения 3:   801f
  Дополнительные сведения 4:   801f6d5ed617f8c201ee3dd761a3f6b7
 
  Сигнатура проблемы:
  Имя события проблемы:   APPCRASH
  Имя приложения:   httpd.exe
  Версия приложения:   2.4.2.0
  Отметка времени приложения:   4f7ed6c4
  Имя модуля с ошибкой:   php5ts.dll
  Версия модуля с ошибкой:   5.3.14.0
  Отметка времени модуля с ошибкой:   4fd8c608
  Код исключения:   c00000fd
  Смещение исключения:   0018b573
  Версия ОС:   6.1.7601.2.1.0.256.1
  Код языка:   1049
  Дополнительные сведения 1:   e339
  Дополнительные сведения 2:   e339f2594e7f681a95b166793376bebb
  Дополнительные сведения 3:   9469
  Дополнительные сведения 4:   946946d25ca9141066f4895df267cf61
Вложения
PHP-5.3.14_php.ini.zip
(4.58 КБ) 57 скачиваний
Apache-2.4.2_error.zip
(1.18 КБ) 69 скачиваний

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 22 июл 2012, 13:44

Отключите библиотеку Xdebug, в ней дело. А с ней видимо никак...

code32
Сообщения: 8
C нами: 4 года 4 мес

Непрочитанное сообщение code32 » 22 июл 2012, 14:51

Максим писал(а):Отключите библиотеку Xdebug, в ней дело. А с ней видимо никак...

Отключил, ничего не изменилось. По прежнему падает.

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 22 июл 2012, 15:22

1) Покажите вывод PHPInfo
2) В руководстве по вашей CMS написано что сервер может падать, и там же написано что надо перезапустить сервер и установку еще раз.

code32
Сообщения: 8
C нами: 4 года 4 мес

Непрочитанное сообщение code32 » 22 июл 2012, 18:01

Максим писал(а):1) Покажите вывод PHPInfo
2) В руководстве по вашей CMS написано что сервер может падать, и там же написано что надо перезапустить сервер и установку еще раз.


1) phpinfo()

2) Уже раз десять перезапустил и переустановил. Каждый раз падает. Каждый раз по новой на чистую, то есть удалял всю CMS и сносил базу.

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 22 июл 2012, 18:09

Ну и зачем вы утверждаете что отключили xdebug, когда это не так? Кароче всё понятно, удачи в переустановках :D

code32
Сообщения: 8
C нами: 4 года 4 мес

Непрочитанное сообщение code32 » 23 июл 2012, 05:00

Ввиду того что его отключение не решило проблему, я включил его назад.

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 23 июл 2012, 08:48

Я не поленился, установил эту CMS, с выключенным xdebug. Да, падает сервер во время установки, как и пишут на форуме этой CMS, но система устанавливается. В любом случае это проблема этой CMS мне кажется, а не PHP.

P.S. Более тормозного говна я еще не видел, страница открывается по 15 секунд..., зачем вам такая CMS да еще и с кривой установкой... Возьмите, например, Slaed CMS очень быстрая. Ну да ладно, вам виднее ;)

code32
Сообщения: 8
C нами: 4 года 4 мес

Непрочитанное сообщение code32 » 23 июл 2012, 18:41

На самом деле просто хотел попробовать, но раз она такая глючная - пожалуй откажусь от этой идеи.


Вернуться в «Модули и инструменты»

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и 1 гость