Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 968 раз!

Форум

Добро пожаловать, Гость!

Символы [] в DocumentRoot

Обсуждение проблем в работе программного комплекса
Yuuki
Сообщения: 6
C нами: 4 года 7 мес

Непрочитанное сообщение Yuuki » 22 июн 2012, 13:59

Апач напрочь отказывается адекватно себя вести, если в DocumentRoot встречаются эти символы. Тупо не видит ничего в указанной директории. Непорядок... :?

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 23 июн 2012, 00:57

Проверяю...

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 23 июн 2012, 20:28

Выяснил, что апач то видит все, но доступа к папке не даёт. В след. версии запрещу данные символы и некоторые другие к использованию. Спасибо.

Yuuki
Сообщения: 6
C нами: 4 года 7 мес

Непрочитанное сообщение Yuuki » 25 июн 2012, 12:39

Максим писал(а):Выяснил, что апач то видит все, но доступа к папке не даёт. В след. версии запрещу данные символы и некоторые другие к использованию. Спасибо.

Жаль. А без запрета никак? Экранировать там или ещё что... Привык к структуре директорий, а там повсюду такие скобки.

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 25 июн 2012, 12:47

Экранировал я, конечно же, но ничего не вышло. Apache побоку... он то запускается но доступа в папку не даёт. Если вы не использовали внешнюю папку для сайтов, то для вас ничего вообще не изменится, просто сервер размещенный в вашей папке станет создавать при запуске виртуальный диск, вот и всё.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и 1 гость