Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 054 раза!

Форум

Добро пожаловать, Гость!

Краш апача в OpenServer начиная с версии 4.1.2

Обсуждение проблем в работе программного комплекса
haste39
Сообщения: 1
C нами: 4 года 6 мес

Непрочитанное сообщение haste39 » 06 июн 2012, 10:24

ОпенСервер начиная с версии 4.1.2, краш апача, явно проявилось при работе с битрикс 11 версии, в джумле при сохранении недоступного для записи конфига, работая на денвере с этими же скриптами все нормально.

Добавлено спустя 16 часов 35 минут 27 секунд:
Возможно апач падает из за конфликта кодировки, т.к если выставить в настройках ОпенСервера кодировку HTTP сервера "Не задано", все норм, до этого стояла utf-8 везде.
Вложения
краш.jpg

And
Сообщения: 14
C нами: 4 года 6 мес

Непрочитанное сообщение And » 10 июн 2012, 11:18

Аналогично. Причем такая же ситуация и на denwer, что дает предположить наличие ошибки в самом apache + php. На denwer, кстати говоря - mod_php

AkimovNY
Сообщения: 14
C нами: 4 года 5 мес
Откуда: Калуга
Контакты:

Непрочитанное сообщение AkimovNY » 13 июн 2012, 09:56

Аналогично, у меня тоже самое. Причем, если выбрать сервер Nginx то все работает нормально, ошибки возникают если сервер Apache + php 5.3 или php 5.4, но если выбрать Apache + php 5.2 то ошибок нет.. Как решить данную проблему?

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 13 июн 2012, 10:27

Дождитесь новой версии и попробуйте на ней

Ganster41
Сообщения: 66
C нами: 4 года 9 мес

Непрочитанное сообщение Ganster41 » 14 июн 2012, 13:58

А какую версию Apache используете? У меня лично 2.4.2 работает гораздо стабильней, чем 2.2.22.
Правда я пользуюсь только PHP 5.2.17...
haste39 писал(а):т.к если выставить в настройках ОпенСервера кодировку HTTP сервера "Не задано"

У меня и стояло всегда "Не задано", и нормально сайт в UTF-8 работает. Так что вообще не вижу смысла трогать эту настройку)

AkimovNY
Сообщения: 14
C нами: 4 года 5 мес
Откуда: Калуга
Контакты:

Непрочитанное сообщение AkimovNY » 14 июн 2012, 14:37

Apache 2.4.2 + php 5.3 Либо php 5.4

AkimovNY
Сообщения: 14
C нами: 4 года 5 мес
Откуда: Калуга
Контакты:

Непрочитанное сообщение AkimovNY » 15 июн 2012, 23:21

в новой версии проблема не решилась(( Apache так же падает

Аватара пользователя
Asmodey
Сообщения: 299
C нами: 4 года 7 мес

Непрочитанное сообщение Asmodey » 17 июн 2012, 14:17

Спробуйте сравнить php.ini от 5.2 и 5.3(5.4). Особо на предмет расширений подозрительных.
У апачи бывает жётская падучая на всякие расширения, некорректно стоящие.
Был прецедент, падал из-за oci (клиента Орекле конечно не было), причём квакал на mbstring.
В режиме cgi такого нет.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 17 июн 2012, 20:26

Apache 2.4.2 совсем новый, зачем вы его используете, он еще не объезженный.

А по поводу ошибки - не знаю от чего конкретно у вас он падает, но может быть дело в старой и известной проблеме mbstring? Если используется полная перегрузка функций библиотекой mbstring то apache и php падают, точнее уже как несколько лет так никто и не знает кто там виноват.

AkimovNY
Сообщения: 14
C нами: 4 года 5 мес
Откуда: Калуга
Контакты:

Непрочитанное сообщение AkimovNY » 18 июн 2012, 00:02

с Apache 2.2 такая же проблема, mbstring удалил из расширений - не помогло


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость