Замена библиотеки libxml

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
alexeews
Сообщения: 2
Зарегистрирован:
30 ноя 2018, 16:58

Замена библиотеки libxml

alexeews » 30 ноя 2018, 17:51

Добрый день!

Суть проблемы, при попытке установки UMI-CMS на развёрнутый сервер получаю сообщение:

«Версия libxml не соответствует системным требованиям на сайте UMI.CMS (Должна быть <= 2.9.4). Для решения проблемы обратитесь к вашему хостинг-провайдеру или системному администратору сервера.»

Заменил файл:

D:\OSPanel\modules\http\Apache-PHP-7-x64\bin\libxml2.dll

На DLL-ку из архива: ХТТП://xmlsoft.org/sources/win32/64bit/libxml2-2.9.3-win32-x86_64.7z

Проблема не разрешилась, вероятно делаю что-то не так (вернул старую библиотеку на место). Подскажите пожалуйста, как лечить.

PS: Версия OSPanel свежая: open_server_5_2_9_ultimate

Спасибо.
Аватара пользователя
Максим
Сообщения: 5414
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Замена библиотеки libxml

Максим » 04 дек 2018, 09:23

Зачем вы меняете файлы? Просто переключитесь на более старый apache и php.
alexeews
Сообщения: 2
Зарегистрирован:
30 ноя 2018, 16:58

Re: Замена библиотеки libxml

alexeews » 05 дек 2018, 01:41

Доброго времени суток!

Спасибо за совет:
Максим писал(а):
04 дек 2018, 09:23
Зачем вы меняете файлы? Просто переключитесь на более старый apache и php.
Помогло. Как-то из головы вылетело, что ранее всегда запускал связку Apache-2.4 + PHP5.6 + MySQL 5.6, ставил UMI-CMS, а уже после переключался на PHP7, впал в ступор – упёрся в стенку.

Тему можно закрывать.

Ещё раз Спасибо!
С уважением,
Александр.
Ответить