Server sent charset unknown to the client. Please, report to the developers

Обсуждение проблем в работе программного комплекса
Get-Web
Сообщения: 2
Зарегистрирован:
13 сен 2018, 13:51

Server sent charset unknown to the client. Please, report to the developers

Get-Web » 15 сен 2018, 23:15

При установке opencart выдает ошибку:
Server sent charset unknown to the client. Please, report to the developers 
Конфигурация:

Apache-2.4
php 5.6 (пробовал еще 5.5)
MySQL 5.6 (пробовал так же 5.5)
Кодировки: MySQL сервер utf8_general_ci

В MySQL-5.6_my.ini записывал:
[client]
default-character-set=utf8

[mysql]
default-character-set=utf8

[mysqld]
collation-server = utf8_unicode_ci
character-set-server = utf8
Не помогло.
Так же бд создавал в разных кодировках, тоже самое
Аватара пользователя
ulukay
Сообщения: 96
Зарегистрирован:
29 мар 2016, 14:02

Re: Server sent charset unknown to the client. Please, report to the developers

ulukay » 16 сен 2018, 10:52

Пытаясь вам помочь, я распаковал оригинальный open_server_5_2_8_premium (с настройками не мудрил кроме как выбрал указанные вами модули (2.4-5.6-5.6)), скачал opencart в папке domains создал opencart.loc (распаковал туда содержимое папки upload), переименовал два файла c:\OSPanel\domains\opencart.loc\admin\config-dist.php и c:\OSPanel\domains\opencart.loc\config-dist.php в config.php. Создал базу с именем opencart_baza (в базе все кодировки по дефолту не чё не трогал) стартанул _http://opencart.loc/install/index.php, И пройдя все 4 шага конфигурации-инсталяции получил рабочий сайт! Даже не знаю чё сказать?!
papdjonn
Сообщения: 42
Зарегистрирован:
24 фев 2012, 14:31

Re: Server sent charset unknown to the client. Please, report to the developers

papdjonn » 16 сен 2018, 16:17

Походу он чет сам там наковырял и не понял че сделал.
Get-Web
Сообщения: 2
Зарегистрирован:
13 сен 2018, 13:51

Re: Server sent charset unknown to the client. Please, report to the developers

Get-Web » 16 сен 2018, 17:56

ulukay, спасибо, уже разобрался. Вчера при установке последней версии openserver понял в чем проблема. У меня MySQL настроен был на порт 3307, а при установке cms естественно по умолчанию 3306. Ввели в заблуждение ответы о кодировке на других форумах... Попытался на обновленном openserver возобновить эту же ошибку, но во всех браузерах вместо Server sent charset unknown to the client. Please, report to the developers теперь просто иероглифы, так что может и ошибка уже не та. Как-то так. Надеюсь кому-то поможет

papdjonn, а вы наверное мастер бесполезных ответов? +1 в копилку, поздравляю
Ответить